Bug 544475 - SELinux is preventing /usr/libexec/gdm-session-worker "read append" access on /root/.xsession-errors.
Summary: SELinux is preventing /usr/libexec/gdm-session-worker "read append" access on...
Keywords:
Status: CLOSED DUPLICATE of bug 543970
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:9a0de3ce0d0...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-05 00:06 UTC by Patrick
Modified: 2009-12-07 15:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-05 11:09:55 UTC


Attachments (Terms of Use)

Description Patrick 2009-12-05 00:06:44 UTC
Summary:

SELinux is preventing /usr/libexec/gdm-session-worker "read append" access on
/root/.xsession-errors.

Detailed Description:

SELinux denied access requested by gdm-session-wor. It is not expected that this
access is required by gdm-session-wor and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                /root/.xsession-errors [ file ]
Source                        gdm-session-wor
Source Path                   /usr/libexec/gdm-session-worker
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gdm-2.28.1-24.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-49.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux zenview.localdomain
                              2.6.31.6-145.fc12.i686.PAE #1 SMP Sat Nov 21
                              16:12:37 EST 2009 i686 i686
Alert Count                   1
First Seen                    Thu 03 Dec 2009 11:54:33 PM EST
Last Seen                     Thu 03 Dec 2009 11:54:33 PM EST
Local ID                      a3f2c99a-17fe-477c-a013-325073d4e524
Line Numbers                  

Raw Audit Messages            

node=zenview.localdomain type=AVC msg=audit(1259902473.372:29885): avc:  denied  { read append } for  pid=1831 comm="gdm-session-wor" name=".xsession-errors" dev=sda10 ino=10448 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=file

node=zenview.localdomain type=SYSCALL msg=audit(1259902473.372:29885): arch=40000003 syscall=5 success=no exit=-13 a0=8fe7208 a1=442 a2=180 a3=8fe7208 items=0 ppid=1809 pid=1831 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="gdm-session-wor" exe="/usr/libexec/gdm-session-worker" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-49.fc12,catchall,gdm-session-wor,xdm_t,admin_home_t,file,read,append
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t admin_home_t:file { read append };

Comment 1 Daniel Walsh 2009-12-05 11:09:55 UTC

*** This bug has been marked as a duplicate of bug 543970 ***


Note You need to log in before you can comment on or make changes to this bug.