Bug 54449 - Installation crashes or certain files are not installed.
Installation crashes or certain files are not installed.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-08 12:01 EDT by Francisco S. Wechsler
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-30 18:48:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Francisco S. Wechsler 2001-10-08 12:01:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (Win98; I)

Description of problem:
Problems: installation never succeeds, using either CD-ROM or hardisk.
(CD image MD5sums are OK, so it's not a downloading error.) Installation 
either crashes or fails to install files.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Try to install RH 7.1 either from CD or hard disk.
2.
3.
	

Actual Results:   Sometimes installation stops (usually when jadetex is 
being installed). Sometimes I can finish the installation process, but 
/tmp/install.log shows that certain components have not been installed, due 
to MD5 errors. The latter problem usually happens to some module belonging 
to /lib/modules/2.4.2-2/kernel/drivers/net (aironet or tulip); 
/usr/lib/libGLU.so.1.1.030401 sometimes is not installed either; sometimes 
some of the fonts.dir are not installed either. Sometimes a segmentation 
fault occurs during installation. Even if I try to correct the installation 
problems by running rpm afterwards, login is erratic: it sometimes hangs, 
or eth0 will not be recognized, or X11 crashes. It is hard to pinpoint the 
cause of the problem, because the results vary.
In my last attempt, I told the BIOS the OS is not PnP-aware, and 
installation crashed, generating the attached file.

Expected Results:    Installation should have proceeded smoothly, with all 
requested components being installed.

Additional info:

Equipment: PC100 motherboard, with SIS530 chipset and K6-3 450MHz 
microprocessor; RAM=256M; 10GB hard-disk with 5GB partition for Windows and 
5GB for Linux. I have run Checkit for Windows, and no problems have been 
detected in my machine.
Comment 1 Michael Fulbright 2001-10-11 10:58:18 EDT
Could you try 'ide=nodma' on the boot command line - some CD drives have
problems when the kernel activates dma mode automatically.
Comment 2 Francisco S. Wechsler 2001-10-16 11:37:57 EDT
  Due to Internet shutdown at our facilities, I haven't been able to reply 
sooner.
  I followed your suggestion, using the "ide=nodma" not only for installation, 
but also as an option for normal LILO boot. Installation from hard disk ISO 
images terminated normally, but /tmp/install.log revealed that some files had 
not been installed, due to MD5sum error. Kernel also complained "No IRQ known 
for interrupt pin A of device 00:00.1. Please try using pci=biosirq."
  I then tried reinstalling, using both "ide=nodma" and "pci=biosirq". Same kind 
of problems in /tmp/install.log, but files affected varied according to trial. 
  A few more details about my machine: BIOS is AMI 1998 (setup utility 1.2.0). 
Hardisk is Quantum Fireball CX10.2A; size = 10258; cyl=1247; head=255; WPcom=0; 
Sec=63; LBA=on; Blk=on; PIO=on; PIO-Mode=4; 32-Bit=on. CDROM PIO=4 32-Bit=on.
  I also fiddled a bit with the BIOS (AMI Setup Utility v. 1.2.0). I left HD 
detection automatic; PnP detection automatic (was user); disabled video 32 K 
shadow; disabled USB. Reinstallation terminated normally, but similar MD5sum 
problems were detected in log file, plus a segmentation fault: 
var/tmp/rpm-tmp-38669: line 1: 817 segmentation fault /sbin/mkkerneldoth.
  Login sometimes hangs; reboot also hangs sometimes.
  Dmseg yields the following:
Linux version 2.4.2-2 (root@porky.devel.redhat.com) (gcc version 2.96 20000731 
(Red Hat Linux 7.1 2.96-79)) #1 Sun Apr 8 19:37:14 EDT 2001
BIOS-provided physical RAM map:
 BIOS-e820: 000000000009fc00 @ 0000000000000000 (usable)
 BIOS-e820: 0000000000000400 @ 000000000009fc00 (reserved)
 BIOS-e820: 0000000000020000 @ 00000000000e0000 (reserved)
 BIOS-e820: 000000000f6f0000 @ 0000000000100000 (usable)
 BIOS-e820: 0000000000008000 @ 000000000f7f0000 (ACPI data)
 BIOS-e820: 0000000000008000 @ 000000000f7f8000 (ACPI NVS)
 BIOS-e820: 0000000000001000 @ 00000000fec00000 (reserved)
 BIOS-e820: 0000000000001000 @ 00000000fee00000 (reserved)
 BIOS-e820: 0000000000040000 @ 00000000fffc0000 (reserved)
On node 0 totalpages: 63472
zone(0): 4096 pages.
zone DMA has max 32 cached pages.
zone(1): 59376 pages.
zone Normal has max 463 cached pages.
zone(2): 0 pages.
zone HighMem has max 1 cached pages.
Kernel command line: auto BOOT_IMAGE=linux ro root=302 
BOOT_FILE=/boot/vmlinuz-2.4.2-2 ide=nodma pci=biosirq
ide_setup: ide=nodmaIDE: Prevented DMA
Initializing CPU#0
Detected 451.022 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 897.84 BogoMIPS
Memory: 247256k/253888k available (1363k kernel code, 6244k reserved, 92k data, 
232k init, 0k highmem)
Dentry-cache hash table entries: 32768 (order: 6, 262144 bytes)
Buffer-cache hash table entries: 16384 (order: 4, 65536 bytes)
Page-cache hash table entries: 65536 (order: 7, 524288 bytes)
Inode-cache hash table entries: 16384 (order: 5, 131072 bytes)
VFS: Diskquotas version dquot_6.5.0 initialized
CPU: Before vendor init, caps: 008021bf 808029bf 00000000, vendor = 2
CPU: L1 I Cache: 32K (32 bytes/line), D cache 32K (32 bytes/line)
CPU: L2 Cache: 256K (32 bytes/line)
CPU: After vendor init, caps: 008021bf 808029bf 00000000 00000002
CPU: After generic, caps: 008021bf 808029bf 00000000 00000002
CPU: Common caps: 008021bf 808029bf 00000000 00000002
CPU: AMD-K6(tm) 3D+ Processor stepping 01
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.37 (20001109) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: AMD K6
PCI: PCI BIOS revision 2.10 entry at 0xfdb81, last bus=1
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Using IRQ router SIS [1039/0008] at 00:01.0
PCI: Cannot allocate resource region 9 of bridge 00:02.0
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.14)
Starting kswapd v1.8
Detected PS/2 Mouse Port.
pty: 256 Unix98 ptys configured
block: queued sectors max/low 164098kB/54699kB, 512 slots per queue
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
SIS5513: IDE controller on PCI bus 00 dev 01
PCI: No IRQ known for interrupt pin A of device 00:00.1.
SIS5513: chipset revision 208
SIS5513: not 100% native mode: will probe irqs later
SiS530
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:DMA, hdd:DMA
hda: QUANTUM FIREBALL CX10.2A, ATA DISK drive
hdd: CREATIVE CD5233E, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: 20044080 sectors (10263 MB) w/418KiB Cache, CHS=1247/255/63
Partition check:
 hda: hda1 hda2 hda3 < hda5 hda6 >
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
Serial driver version 5.02 (2000-08-09) with MANY_PORTS MULTIPORT SHARE_IRQ 
SERIAL_PCI ISAPNP enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
Real Time Clock Driver v1.10d
md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md.c: sizeof(mdp_super_t) = 4096
autodetecting RAID arrays
autorun ...
... autorun DONE.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 2048 buckets, 16Kbytes
TCP: Hash tables configured (established 16384 bind 16384)
Linux IP multicast router 0.06 plus PIM-SM
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 232k freed
Adding Swap: 530104k swap-space (priority -1)
Winbond Super-IO detection, now testing ports 3F0,370,250,4E,2E ...
SMSC Super-IO detection, now testing Ports 2F0, 370 ...
0x378: FIFO is 16 bytes
0x378: writeIntrThreshold is 16
0x378: readIntrThreshold is 16
0x378: PWord is 8 bits
0x378: Interrupts are ISA-Pulses
0x378: ECP port cfgA=0x10 cfgB=0x40
0x378: ECP settings irq=<none or set by other means> dma=<none or set by other 
means>
parport0: PC-style at 0x378 (0x778) [PCSPP,TRISTATE,COMPAT,ECP]
parport0: irq 7 detected
parport0: Found 1 daisy-chained devices
parport0: No more nibble data (1 bytes)
parport0: device reported incorrect length field (61, should be 62)
parport0 (addr 0): SCSI adapter, IMG VP1
PCI: Found IRQ 10 for device 00:0d.0
Davicom DM91xx net driver loaded, version 1.30 (June 11, 2000)

  I hope these additional details may prove useful to you. Meanwhile, I shall 
take the machine for a thorough hardware checkup. As soon as checkup is finished 
I shall send you a report
Comment 3 Brent Fox 2001-10-16 12:11:34 EDT
The md5sum errors concern me.  Can you check the md5sum of the ISO images and
make sure that they weren't corrupted during the download somehow?
Comment 4 Francisco S. Wechsler 2001-10-19 11:11:39 EDT
  The ISO images were downloaded via WS_FTP-PRO on Win 98. As stated before, I 
did check the MD5sums of the ISO images after download. I recently checked them 
once more, running 'md5sum.exe' on Win 98. Here are the results:
596b1575773e88e066326f6741312a6f *seawolf-i386-disc1.iso
f27b912299572a542cd663b712444445 *seawolf-i386-disc2.iso
  In fact, disc1.iso had been downloaded twice, from two different mirrors, with 
 identical MD5sums.
  I also had a thorough hardware checkup done (on Windows), but no abnormalities 
 were found.
  I have also tried disabling ultra-dma HD via BIOS _and_ using ide=nodma  
simultaneously. I have tried installing RH 7.1 several times via HD. The 
problems persist: sometimes the installation aborts, sometimes it proceeds 
normally, but not all files are properly installed due to MD5sum errors, 
according to  /tmp/install.log. I once got the message: "an error occurred while 
installing the bootloader - error - fatla: open /dev/hda: no such file or 
directory. Another trial yielded an internal error message:

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 520, in ?
    
intf.run(todo, test = test)
  File 
"/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 1126, in run
  File 
"/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 551, in __call__
  File 
"/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1852, in doInstall
  
File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1564, in 
instCallback
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/harddrive.py", line 
159, in getFilename
  File 
"/var/tmp/anaconda-7.1//usr/lib/anaconda/harddrive.py", line 116, in 
umountMedia
  File "/usr/lib/anaconda/isys.py", line 140, in umount
    rc = 
_isys.umount(what)
SystemError: (16, 'Device or resource busy')

Local variables 
in innermost frame:
what: /tmp/hdimage
removeDir: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'resState'
p3
S''
sS'progressWindow'
p4
(itext
ProgressWindow
(dp5
S'scale'
p6
NsS'screen'
p7
(isnack
SnackScreen
p8
(dp9
S'height'
p10
I25
sS'width'
p11
I80
sS'helpCb'
p12

<failed>


  Machines that use "everything on board" technology like mine are known to be 
less reliable. It seems there is some subtle incompatibility between my machine 
and RH 7.1, which I have been unable to track down so far. If you would like me 
to run additional tests, please let me know.
Comment 5 Brent Fox 2001-10-22 17:10:12 EDT
Do you care to try 7.2 and see if that helps?
Comment 6 Francisco S. Wechsler 2001-10-22 17:47:46 EDT
  I will certainly try it and send you a report in the next few days.
Comment 7 Brent Fox 2001-10-22 21:35:34 EDT
Ok.  Here's hoping it fixes the problem.
Comment 8 Francisco S. Wechsler 2001-10-30 14:11:44 EST
  Sorry for the delay; Internet was down again several times last week. I tested 
RH 7.2, and the problems are basically the same. I used the same ISO images on 
another computer (ASUS motherboard, dual Pentium-III, 512 MB RAM), and 
installation proceeded normally. It looks like some kind of incompatibility 
between the 2.4.x kernels and my machine. Maybe this kind of equipment should be 
put on the "black list"? I am still running additional memory tests, using 
memtest86. I shall report the results of these tests, too. Should you have any 
further questions, please let me know.
Comment 9 Francisco S. Wechsler 2001-10-30 18:48:24 EST
 I've just finished running MemTest-86 v2.8. It does indeed report memory errors 
in test #5 (9284 to be exact!). Wrong addresses are not consecutive and there's 
always 1 wrong bit per adddress, although the wrong bit position in the address 
varies. None of this seems to bother Win98.
Comment 10 Brent Fox 2001-10-30 23:22:23 EST
Hmm...well, who knows how Win98 handles memory?  Nobody's allowed to see.  I'm
going to close this report since it seems to be hardware problems.  Please
reopen this report if you see the behavior on a system that passes MemTest-86. 
Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.