Bug 54452 - Out of disk space makes console unusable
Summary: Out of disk space makes console unusable
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gdm (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-08 16:21 UTC by Alan Cox
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-11 22:25:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alan Cox 2001-10-08 16:21:54 UTC
Fill the / partition as a user (not even root needed)
Reboot

If you are using gdm then the sequence goes

starting xfs        Ok
but xfs then bombs out with no disk space to make its socket

gdm starts, and dies and starts and dies looping continually. A non
technical user is basically at "reinstall" level when this happens so I
count it as pretty serious.

We need to issue a gdm that is at least smart enough to bail out when X
wont start, or back off a sensible timeout. Note that Jirka's experimental
fall back to VGA mode stuff won't help in this specific case either.

I've not tested kdm

Alan

Comment 1 Havoc Pennington 2001-10-08 16:37:37 UTC
gdm is supposed to detect looping, and does normally. Perhaps its detection
involves writing to disk...



Comment 2 Alan Cox 2001-10-08 16:44:56 UTC
I don't believe so. You see flick flick flick pause flick flick flick pause type
patterns so does gdm exit when looping and whatever ran it rerun it straight off ?

Simple demo its not gdm using disk

telinit 3
/etc/rc.d/init.d/xfs stop
telinit 5

and it loops and loops...


Comment 3 George Lebl 2001-10-09 03:15:23 UTC
eek, pretty evil. I'm trying but I cannot reproduce a state where the loop of
death would not kick in.  What I am thinking is happening is gdm is dying of some
segfault or something of the sort.  The main gdm is not supposed to exit at any
point unless instructed to.  Perhaps try running the main gdm process in gdm and
see if it does exit.  One of the problems here is running gdm from init, which
is evil!!!!  gdm should really run as it's own separate server.  Then init would
never try to restart it.

Does this happen with 2.2.4.1?  I'd also be interested in the output in syslog
with gdm debugging turned on (in gdm.conf section debug do Enable=true).

Comment 4 George Lebl 2001-10-09 04:06:04 UTC
I meant 2.2.4.2

Comment 5 Havoc Pennington 2002-02-11 22:25:49 UTC
Needs to be verified with the new gnome2 gdm alex and jrb are building in rawhide

Comment 6 Havoc Pennington 2002-02-25 17:48:12 UTC
Kicking this upstream as http://bugzilla.gnome.org/show_bug.cgi?id=72541, 
closing on Red Hat level. We will probably get the fix with the GNOME 2 
migration.


Note You need to log in before you can comment on or make changes to this bug.