Bug 54457 - built-in editor show non-latin1 characters as "???"
Summary: built-in editor show non-latin1 characters as "???"
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdevelop (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-08 21:42 UTC by Leonid Kanter
Modified: 2007-04-18 16:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-01 22:39:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Leonid Kanter 2001-10-08 21:42:02 UTC
Description of Problem:

built-in editor show non-latin1 characters as "???"

Version-Release number of selected component (if applicable):

2.0-1

How Reproducible:

always

Steps to Reproduce:
1. start kde
2. in control-center, select koi8-r as default encoding
3. add russian keyboard to kde keyboard list
4. start kdevelop in Russian locale: LANG=ru_RU.koi8r kdevelop
5. Open any text file in editor or create new project.
6. select russian keyboard and try to type something.

Actual Results:

You'll see all characters as "?" on the screen.

Expected Results:

Cyrillic characters must be there.

Additional Information:
	
The same for 2.0.1-1. In built-in console window everything is OK. If you
save text and open it in other editor, it will be OK too.

Comment 1 Ngo Than 2001-10-15 15:04:59 UTC
please update urw-fonts-2.0-13 from rawhide and tell me if this problen is fixed.

Comment 2 Leonid Kanter 2001-10-15 18:37:45 UTC
I'm already using urw-fonts with cyrillic glyphs, but it doesn't matter. There
is wrong QT call somewhere in embedded kwrite, we are trying to figure out, but
with no success yet. In search fields and other forms everything is OK, problem
exists in editor window only.

Comment 3 Ngo Than 2001-10-22 13:06:37 UTC
could you please try the kdevelop-2.0-3.i386.rpm  from
ftp://people.redhat.com/than/7.2.

it should fix this problem. Please let me know if it works

Comment 4 Leonid Kanter 2001-10-23 13:21:46 UTC
I tried (even removed kdeveloprc first). The problem is still present.

Comment 5 Leonid Kanter 2001-12-01 22:39:50 UTC
This bug is fixed in kdevelop-2.0.2-1
Here is changelog entry
2001-10-27  Grisha Mokhin <mokhin@bog.msu.ru>
    * applied patch of Nikita Youshchenko who fixed the incorrect display of
non-latin characters in editor views


Comment 6 Ngo Than 2001-12-03 09:32:36 UTC
we will release kde 2.2.2 soon, if you want kde 2.2.2 now, please take a look at 
ftp://ftp.kde.org/pub/kde/stable/2.2.2/RedHat/7.2/


Note You need to log in before you can comment on or make changes to this bug.