Bug 544590 - Using text tool crashes inkscape
Using text tool crashes inkscape
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
abrt_hash:dd8d19a1f211e00ef32fd6f6d8d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-05 10:56 EST by Luya Tshimbalanga
Modified: 2009-12-17 23:46 EST (History)
7 users (show)

See Also:
Fixed In Version: 2.18.5-3.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-17 23:46:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (8.50 KB, text/plain)
2009-12-05 10:56 EST, Luya Tshimbalanga
no flags Details

  None (edit)
Description Luya Tshimbalanga 2009-12-05 10:56:31 EST
abrt 1.0.0 detected a crash.

How to reproduce
-----
1. Start Inkscape
2. Select text button and click on any page
3.

Comment: Inkscape crashed while trying to input text
Attached file: backtrace
cmdline: inkscape
component: inkscape
executable: /usr/bin/inkscape
kernel: 2.6.31.6-145.fc12.i686
package: inkscape-0.47-1.fc12
rating: 3
reason: Process was terminated by signal 6
Comment 1 Luya Tshimbalanga 2009-12-05 10:56:34 EST
Created attachment 376326 [details]
File: backtrace
Comment 2 Tethys 2009-12-05 13:44:24 EST
This is a major deal for me. I've just upgraded from F11 and inkscape is
now completely unusable. I have some work I need to send to the printer,
and I'm now unable to complete it. This is a disaster. If there's any
other information you need (e.g, a core dump), please let me know.

I really need this fixed ASAP.
Comment 3 Luya Tshimbalanga 2009-12-06 22:00:30 EST
Turned out  the update of gtk2 with gtk2-immodule-xim broke text input in Inkscape. Workaround is to downgrade gtk2 until the issue is resolved.
Comment 4 Tethys 2009-12-07 05:21:46 EST
Alternatively, setting GTK_IM_MODULE=gtk-im-context-simple seems to work,
although it may lose you some functionality.
Comment 5 Fedora Update System 2009-12-09 23:10:48 EST
gtk2-2.18.5-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtk2'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12950
Comment 6 Luya Tshimbalanga 2009-12-10 01:39:44 EST
Üpdating gtk2 resolved the text tool issue.
Comment 7 Fedora Update System 2009-12-17 23:46:31 EST
gtk2-2.18.5-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.