Bug 544629 - at-spi2-atk - GTK+ module that bridges ATK to D-Bus at-spi
Summary: at-spi2-atk - GTK+ module that bridges ATK to D-Bus at-spi
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Nobody's working on this, feel free to take it
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 544628
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-05 19:38 UTC by Matthias Clasen
Modified: 2010-01-06 23:46 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-06 23:46:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kevin: fedora-cvs+


Attachments (Terms of Use)

Description Matthias Clasen 2009-12-05 19:38:49 UTC
The accessibility framework is being rewritten on top of D-Bus to get rid of
ORBit/CORBA. This package is an early release of the core of the new framework.

I'm packaging it now to allow people to start testing and reporting problems. 
For now, the at-spi2 packages will have Conflicts with the at-spi packages.
This
will be replaced by Provides/Obsoletes, once at-spi2 is feature-complete and
ready for prime time.

This package includes a gtk-module that bridges ATK to the new
D-Bus based at-spi. It depends on at-spi2-core, which is under review in bug 544628

SRPM: http://mclasen.fedorapeople.org/at-spi2/at-spi2-atk-0.1.3-1.fc12.src.rpm
Spec: http://mclasen.fedorapeople.org/at-spi2/at-spi2-atk.spec

Comment 1 Matthias Clasen 2009-12-23 02:03:49 UTC
Updated to 0.1.4:

SRPM: http://mclasen.fedorapeople.org/at-spi2/at-spi2-atk-0.1.4-1.fc12.src.rpm
Spec: http://mclasen.fedorapeople.org/at-spi2/at-spi2-atk.spec  

The Conflicts is no longer necessary since I have turned on the relocation support that makes this package coexist peacefully with at-spi

Comment 2 Joshua Roys 2010-01-05 14:14:28 UTC
+ rpmlint (buildroot tag is no longer required, as long as this isn't going into epel 5)
  $ rpmlint at-spi2-atk.spec
  at-spi2-atk.spec: W: no-buildroot-tag
  0 packages and 1 specfiles checked; 0 errors, 1 warnings.
+ package name is fine
+ spec is %{name}.spec
+ meets packaging guidelines
+ meets licensing guidelines
+ license matches (the GNU Library GPL is the precursor to the Lesser GPL)
+ COPYING is in %doc
+ spec is in American English
+ spec is legible
+ sources match
? build (I can't convince my mock to get the repodata from a mirror that has at-spi2-core in it... but I'm assuming this builds fine)
+ no ExcludeArch
+ build deps listed
+ no locales
+ no shared libraries in default paths
+ doesn't bundle a copy of a system library
+ not relocatable
+ directories appear sane
+ %files doesn't contain duplicates
+ %files has %defattr
+ %clean is correct
+ spec macros used consistently
+ package contains code
+ no large docs
+ %doc files are not required to run
+ no header files
+ no static libraries
+ no pkgconfig files
+ .so does not have trailing numbers
+ no -devel package
+ no .la files (removed in %install phase)
+ no gui applications
+ no duplicate file/dir ownership
+ %install clears buildroot
+ filenames are valid utf-8

so long as it builds for you in mock/koji,
APPROVED

Comment 3 Matthias Clasen 2010-01-05 14:49:10 UTC
New Package CVS Request
=======================
Package Name: at-spi2-atk
Short Description: A GTK+ module that bridges ATK to D-Bus at-spi
Owners: mclasen
Branches: 
InitialCC:

Comment 4 Kevin Fenzi 2010-01-06 21:31:50 UTC
cvs done.

Comment 5 Matthias Clasen 2010-01-06 23:46:32 UTC
built


Note You need to log in before you can comment on or make changes to this bug.