Bug 544656 - Release notes and other documentation require Javascript to read
Summary: Release notes and other documentation require Javascript to read
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora Documentation
Classification: Fedora
Component: fedora-websites
Version: devel
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Ruediger Landmann
QA Contact: Karsten Wade
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-05 21:33 UTC by Scott Mcdermott
Modified: 2010-06-06 00:08 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-06 00:08:49 UTC


Attachments (Terms of Use)

Description Scott Mcdermott 2009-12-05 21:33:05 UTC
Description of problem:
Release notes and other documentation require Javascript capable browsers to read online.

How reproducible:
Every time.


Steps to Reproduce:
1. go to fedoraproject.org in elinks or lynx
2. select the "read the release notes" link
3. follow refresh to docs.fedoraproject.org
4. try in vain to read the release notes: no form submit button, uses onChange() javascript for form selector element
  
Actual results:

cannot read fedora documentation on a machine without X and graphical browser


Expected results:

be able to read fedora documentation prior to downloading the operating system, without having a graphical interface available.


Additional info:

This is UNIX.  Please don't require a graphical browser to access the documentation!

Comment 1 Tom "spot" Callaway 2009-12-05 21:40:56 UTC
No, this is Linux. "UNIX" is a trademark of the "The Open Group", and only Operating Systems which are fully compliant with and certified to the Single UNIX Specification qualify as "UNIX". Linux is not certified to the Single UNIX Specification, so Linux is not UNIX. 

Not that it takes away from the meat of your bug in any way.

Comment 2 Scott Mcdermott 2009-12-05 22:17:41 UTC
Not that it has any relation to this bug, but Linux is definitely a UNIX in the colloquial sense it was used.  Just because it's not "officially" stamped by TOG/Austin, does not mean it's not a UNIX.  It's probably 98% compliant with SUS/POSIX/CXX/UNIXYY standards.  The kernel and userland were written from the beginning as a (loose) reimplementation of (loose reimplementations of) AT&T and some BSD interfaces.  You're going to say it's not a UNIX operating system?

"This is UNIX" in the context of requiring a graphical browser to view release notes for the operating system obviously has a particular meaning that has nothing to do with whether it's received a compliance stamp by the specification.  And that meaning is that it's by/for/historically text-based.  Since I started using RedHat in 3.x days it has never required me to use a graphical browser to view the release notes.  Ditto for any other UNIX I've worked with, which is the origin of the comment you pedanticized.

Already many of my colleagues have been scared off from RedHat by the disturbing "desktop" bias evident in Fedora, but as the genesis of RHEL, I'm concerned that things like requiring a GUI browser to view release notes is going a little too far.  This isn't Ubuntu guys.  A lot of us are still fbcon users that don't fire up X unless a suit sends an Office document.  And even then we try as hard as we can to use "antiword" or "xlhtml" or whatever.  Please don't force us to run X to view release notes.  I know that we can get them from FTP or something like that, but there's a plethora of other information at fedoraproject.org and I think it makes sense to make that as accessible as possible to all the users of the operating system, not just desktop users.

Comment 3 Karsten Wade 2009-12-05 23:28:10 UTC
Back on topic, I'd like to step in and make a few points, then some suggestions:

* The changes you see on docs.fedoraproject.org were a stop-gap until a proper CMS can be installed to serve Fedora docs.  Let's presume for a moment that the CMS has the capability of serving plain-ASCII and text-browser friendly content, so the problem is temporary.

* These changes were made during the F12 development cycle when it was clear the CMS couldn't be done in time to match Fedora Infrastructure freeze cycles and CMS Packaging needs.  The changes have been visible for some time.

* The old page that was replaced by this JavaScript-using solution had a number of problems of its own that reduced usability to other classes of users.  While it's not ideal to swap problems of one user group for another, perhaps it's OK in this case as a temporary stop-gap.

Some suggestions:

1. Enable directory browsing on the per-release sub-folders.  E.g. http://docs.fedoraproject.org/release-notes/f12/ now redirects back to the top page.  If it didn't, I could view the many language and format options and manually drill down to http://docs.fedoraproject.org/release-notes/f12/en-US/html/.

2. Put a link on the front page in a prominent location that goes to the top-level directory for each major document.  For example, the first time your see Release Notes it could be followed by "(browse directories manually)" as a link to http://docs.fedoraproject.org/release-notes/f12/ or http://docs.fedoraproject.org/release-notes/f11/.

3. Put a README in each directory (release-notes/f12, etc.) that is the similar to what is in the current index page -- "Note: you are manually crawling a directory structure.  If you want a graphical, organized view to browse the documents, go to the top-level site at http://docs.fedoraproject.org"

Do these sound reasonable?  I can help start working on the three items; the first is going to require interaction with Fedora Infrastructure and I don't know what challenges we'll run in to there.

Comment 4 Scott Mcdermott 2009-12-09 19:37:01 UTC
you could just add a submit button to each <form> and leave onChange too, or remove that so everyone would have to click submit.

Comment 5 Robert 'Bob' Jensen 2010-04-13 15:28:05 UTC
This is being worked on for the F13 release. Docs will be taking advantage of the web publishing feature built into the forthcoming version of Publican.

Comment 6 Robert 'Bob' Jensen 2010-05-05 16:19:49 UTC
So we are 2 weeks from the F13 release, when can we expect to see the promised output from publican?

Comment 7 eric 2010-06-04 13:41:00 UTC
I believe this has been remedied.  Can you please verify this, please?

Comment 8 Bruno Wolff III 2010-06-04 14:27:28 UTC
Getting the release notes in the default language (en_US) is fine now.
Using the map alt link is a bit confusing as the links at the top still need the redirect and the space is limited enough that you don't see the per language, per document links without scrolling. Those links do work though. If you start from the main docs page instead of the English release notes, it also works better as the whole screen gets used for the links and you can see the ones you need easier.

Comment 9 eric 2010-06-04 15:14:01 UTC
(In reply to comment #8)

What you are seeing is still a work in progress but I think it fixes a lot of the problems we were seeing before.  Is the current solution a remedy of your original request?

Comment 10 Bruno Wolff III 2010-06-04 15:28:28 UTC
I am not the original reporter, but for myself I think the issue is solved.

Comment 11 Scott Mcdermott 2010-06-06 00:08:49 UTC
Works for me fine now using text browser with no JS.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.