Bug 544830 - WS findDataForResource returns no data
WS findDataForResource returns no data
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Web Services (Show other bugs)
1.3
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Simeon Pinder
: SubBug
Depends On:
Blocks: rhq_triage
  Show dependency treegraph
 
Reported: 2009-12-06 12:38 EST by Simeon Pinder
Modified: 2014-05-09 12:04 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.3.1 1.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-09 12:04:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Simeon Pinder 2009-12-06 12:38:45 EST
Description of problem:
Calling the method findDataForResource always returns an empty list.


Version-Release number of selected component (if applicable):
Jon 2.3

How reproducible:
Every time.  See below.

Steps to Reproduce:
1. Start up a JON instance with WS interface enabled and generate platform specific types from the WSDL. 
2. Populate a JON instance with a resource that has associated schedules(ex. JBoss AS 4.2.3 instance.)
3. Login and call findDataForResource(). 
  
Actual results:
The returned list is empty.

Expected results:
A list of MeasurementDataNumericHighLowComposite types should be returned.

Additional info:
Looks like the translation of types is mangled by JbossWS.
Comment 1 Charles Crouch 2009-12-15 15:49:21 EST
Consider in 1.3.1 triage
Comment 2 wes hayutin 2010-02-16 11:59:21 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 3 wes hayutin 2010-02-16 12:04:29 EST
making sure we're not missing any bugs in rhq_triage
Comment 4 Corey Welton 2010-10-05 09:18:00 EDT
Triaged 30-Sep
Comment 5 Jay Shaughnessy 2014-05-09 12:04:11 EDT
WebServices are no longer supported.

Note You need to log in before you can comment on or make changes to this bug.