Bug 544852 - unixODBC GUI part is not working
Summary: unixODBC GUI part is not working
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: unixODBC
Version: 12
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Tom Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 548898 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-06 19:21 UTC by Lukasz Wrzosek
Modified: 2013-07-03 03:25 UTC (History)
3 users (show)

Fixed In Version: 2.2.14-9.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 554501 (view as bug list)
Environment:
Last Closed: 2009-12-22 04:52:23 UTC
Type: ---


Attachments (Terms of Use)
Patch adds ItemIsEnabled flag to all QWidgetTable Items and makes Driver selectableP (2.61 KB, patch)
2009-12-06 21:06 UTC, Lukasz Wrzosek
no flags Details | Diff

Description Lukasz Wrzosek 2009-12-06 19:21:51 UTC
Description of problem:
I cannot select Odbc Driver from Drivers List when adding new DataSource.
(Data Sources Names -> User -> Add -> 'select driver from the list' -> Ok)

Version-Release number of selected component (if applicable):
unixODBC-2.2.14-6.fc12.i686

How reproducible:
Allways

Steps to Reproduce:
1.Run ODBCConfig
2.Select DataSourceNames from the menu on the left
3.Select User Tab
4.Click on any Odbc Drivers from the table
5.Click Ok button
  
Actual results:
Allways popups window with 'please select a Driver' information.

Expected results:
Driver is selected, application flow continues

Additional info:
I could not find any bugs list on unixODBC page.

Comment 1 Lukasz Wrzosek 2009-12-06 21:06:16 UTC
Created attachment 376515 [details]
Patch adds ItemIsEnabled flag to all QWidgetTable Items and makes Driver selectableP

Comment 3 Tom Lane 2009-12-20 00:21:09 UTC
Yup, that does seem to help.  Added to  unixODBC-2.2.14-9, thanks for the patch!

Comment 4 Tom Lane 2009-12-20 00:22:25 UTC
*** Bug 548898 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2009-12-22 04:52:19 UTC
unixODBC-2.2.14-9.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.