Bug 545000 - xen needs to be tested with grub2
xen needs to be tested with grub2
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Xen Maintainance List
Red Hat Kernel QE team
: Reopened, TestOnly
Depends On:
Blocks: 514491
  Show dependency treegraph
 
Reported: 2009-12-07 04:47 EST by Paolo Bonzini
Modified: 2011-07-29 03:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-29 03:11:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paolo Bonzini 2009-12-07 04:47:33 EST
> latest grub had changed to "don't pass filename in multiboot
> command line".
> 
> The old cmdline format is: "module-name options..."
> The new cmdline format is: "options..."
> 
> So xen + grub2 always loss the first option, because xen will
> skip the first option.

Can be tested by installing e.g. RHEL5 and Ubuntu 9.10 on the same boot block.

The thread including http://permalink.gmane.org/gmane.comp.emulators.xen.devel/75161 outlines two possible approaches.

Progress of GRUB2 in Fedora is at http://fedoraproject.org/wiki/Features/Grub2
Comment 2 Laszlo Ersek 2011-06-20 09:16:31 EDT
This problem was fixed in upstream grub-2 (bzr revno 2480):

2010-06-28  Vladimir Serbinenko  <phcoder@gmail.com>

        XEN with Linux grub-mkconfig support.

        * conf/common.rmk (grub-mkconfig_SCRIPTS) [linux]: Add 20_linux_xen.
        * util/grub-mkconfig.in: Export GRUB_CMDLINE_XEN and
        GRUB_CMDLINE_XEN_DEFAULT.
        * util/grub.d/20_linux_xen.in: New file.

Upstream tracker:
http://savannah.gnu.org/bugs/?28548#history

Corresponding Debian bug closed by upstream:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=557645#30
Comment 3 Paolo Bonzini 2011-06-27 07:03:53 EDT
Did you test it?  If you didn't, this should be reopened as TestOnly.
Comment 4 Laszlo Ersek 2011-06-27 07:58:04 EDT
As you wish.

Note You need to log in before you can comment on or make changes to this bug.