Bug 54510 - Tracebacks if put space in Address1 in rhn_register
Summary: Tracebacks if put space in Address1 in rhn_register
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend   
(Show other bugs)
Version: RHN Devel
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-10 18:25 UTC by Jay Turner
Modified: 2015-01-07 23:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-15 19:45:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jay Turner 2001-10-10 18:25:40 UTC
Description of Problem:
If the user sets Address1 to one of more spaces, then it does not get
populated with the default of "." and therefore when we attempt to insert
into the web_user_site_info record, we get a traceback.  The error is:

Traceback (innermost last):
  File "/var/www/rhns/server/apacheServer.py", line 37, in __call__
    ret = f(req)
  File "/var/www/rhns/server/rhnServer.py", line 163, in handler
    ret = self.__xmlrpcCall(server, methodName, params, req)
  File "/var/www/rhns/server/rhnServer.py", line 507, in __xmlrpcCall
    raise rhns_oracle.OracleError(e)
OracleError: (1407, 'ORA-01407: cannot update
+("WEB"."WEB_USER_SITE_INFO"."ADDRESS1") to NULL\012', {'SQL': 'update
+web_user_site_info set alt_first_names = :p_alt_first_names, state =
+:p_state, country = :p_country, alt_last_name = :p_alt_last_name, address1 =
+:p_address1 where id = :p0', 'Params': [(':p0', 2049647), (':p_address1',
+''), (':p_alt_first_names', 'C'), (':p_alt_last_name', 'Bailey'),
+(':p_country', 'CA'), (':p_state', 'British Columbia')]})

Version-Release number of selected component (if applicable):


How Reproducible:
Always

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:
Need to make sure that spaces count as null and therefore those mandatory
fields get populated with "."

Additional Information:

Comment 1 Josef Komenda 2002-03-20 16:40:34 UTC
Bret McMillian taking a look at this - but holding off on assigning it for now.

Comment 2 Cristian Gafton 2002-04-11 08:56:46 UTC
This need to be fixed in the rhn_register itself. Assigning to alikins

Comment 3 Adrian Likins 2002-04-11 19:14:58 UTC
The error looks like a oracle server side error to me, but
either way, I cant seem to duplicate this with the client.

jay/joe: Mind showing me how to trigger it?

Comment 4 Adrian Likins 2002-05-15 19:45:43 UTC
ping, can duplicate this... gonna close if no other info

Comment 5 Josef Komenda 2002-07-16 15:45:12 UTC
Seems to work fine. Closing.


Note You need to log in before you can comment on or make changes to this bug.