Bug 545109 - Syntax error in init script
Syntax error in init script
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: microcode_ctl (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Kyle McMartin
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-07 11:01 EST by Bruno Wolff III
Modified: 2015-08-31 23:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-08 15:09:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2009-12-07 11:01:49 EST
Description of problem:
[root@cerberus bruno]# service microcode_ctl restart
/etc/init.d/microcode_ctl: line 59: syntax error near unexpected token `}'
/etc/init.d/microcode_ctl: line 59: `}'
[root@cerberus bruno]# rpm -q microcode_ctl
microcode_ctl-1.17-1.56.fc12.x86_64

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mace Moneta 2009-12-08 10:33:49 EST
I'm seeing the same thing after updating microcode_ctl yesterday.
Comment 2 Kyle McMartin 2009-12-08 15:09:45 EST
It's fixed in 1.17-1.57...
Comment 3 Eddie Lania 2009-12-28 16:16:32 EST
I'm seeing the same thing happening here.

When will it be fixed in FC12?

[root@p3000fedora init.d]# service microcode_ctl status
/etc/init.d/microcode_ctl: line 59: syntax error near unexpected token `}'
/etc/init.d/microcode_ctl: line 59: `}'

[root@p3000fedora init.d]# rpm -qa |grep -i microcode
microcode_ctl-1.17-1.56.fc12.i686
Comment 4 Mads Kiilerich 2009-12-28 16:28:21 EST
Eddie: It will be pushed as an update when you (and enough others) have tested 1.17-1.57 and given it good karma on http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12787
Comment 5 Eddie Lania 2009-12-28 16:41:02 EST
1.17-1.57 is not in updates-testing:

microcode_ctl.i686               1:1.17-1.56.fc12                updates-testing

Unless somebody pushes it to updates-testing, I can't give my 'karma' on it.

Happy new year!
Comment 6 Mads Kiilerich 2009-12-28 16:49:05 EST
Eddie: Sorry, you are right. I must have downloaded it from koji when I tested it. Perhaps you could do the same.
Comment 7 Eddie Lania 2009-12-28 17:09:39 EST
Okay, I updated it.

I can see during start up that the " [OK] " is missing. I don't use graphical boot.

The output in /var/log/messages however seems to be good, although I have an older CPU and don't see any change in the firmware.
Comment 8 Bruno Wolff III 2009-12-28 18:16:05 EST
I have tried out -57 and the syntax error message no longer appears. I am not sure why it didn't get pushed to updates-testing. -56 is still in updates-testing which isn't good.

Note You need to log in before you can comment on or make changes to this bug.