Bug 54513 - up2date ignores proxy settings
up2date ignores proxy settings
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-10 15:53 EDT by Jason Kohles
Modified: 2015-01-07 18:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-22 14:00:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Kohles 2001-10-10 15:53:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010816

Description of problem:
After upgrading from seawolf to roswell, I attempted to use up2date to
upgrade through the beta rhn server.  I used up2date-config to enable proxy
settings, and entered the ip address and port of the proxy server, I then
verified that the proxy settings were in /etc/sysconfig/rhn/up2date and ran
up2date, it hangs attempting to download package list, and running strace
on the process shows it is attempting to connect to port 80 on
beta.rhns.redhat.com, rather than to port 3128 on the proxy server.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Upgrade to roswell
2.Configure up2date to use a proxy
3.run up2date
	

Additional info:
Comment 1 Jay Turner 2001-10-10 16:14:19 EDT
Grab the latest up2date packages (as well as python-xmlrpc if you don't have it)
and install those and see what happens.
Comment 2 Jason Kohles 2001-10-10 16:23:03 EDT
These are the versions I have installed now:

python-xmlrpc-1.4.5-0.7.x
up2date-2.6.0-7.x.29
up2date-gnome-2.6.0-7.x.29

I haven't been able to find anything newer than these, if there are newer
versions, please let me know where to find them...

Comment 3 Jay Turner 2001-10-10 16:40:17 EDT
Oops . . . meant to include a link to the latest stuff.  Head to
http://people.redhat.com/jturner/software.html
Comment 4 Jason Kohles 2001-10-22 14:00:43 EDT
This bug appears to be fixed prior to release, I cannot reproduce it in Enigma,
so go ahead and close it...

Note You need to log in before you can comment on or make changes to this bug.