Bug 545196 - snmptrapd plugin should use list-o-maps, not MibTrans.properties
snmptrapd plugin should use list-o-maps, not MibTrans.properties
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
unspecified
All All
low Severity low (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
: EasyFix, FutureFeature, Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-07 15:28 EST by John Mazzitelli
Modified: 2014-05-16 15:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-16 15:56:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2009-12-07 15:28:45 EST
This is an easy one to implement I think.

First, read:

http://www.rhq-project.org/display/RHQ/Plugins+-+Snmptrapd

Notice that the plugin jar has MibTrans.properties embedded in it that contains the maps of oids:

"The plugin currently has no mib parser, so the generated event payload is passed as 'oid: value' into the events.
It is possible though to define a manual mapping. There is a file MibTrans.properties within the plugin, that maps oids to names"

There is no need to have this extra .properties file because we can use the plugin configuration to store that mapping.

this would allow us to:

a) create the mapping in the GUI
b) update the mapping in the GUI without cracking open the existing jar and updating it and then pushing out the entire plugin jar to all agents so the new update it found
c) perform group configuration across multiple snmptrapd resources

What we need to do is:

1) remove the MibTrans.properties file from the jar file completely - totally delete it
2) create a simple list-of-map property in the <plugin-configuration> metadata of the plugin. The map has two simple properties - one for oid and one for name - we can even have the oid property be forced to validate against a regex to make sure the user enters a valid oid
3) have the plugin component no longer read the .properties file but instead get the mappings from the plugin configuration.

This should only be an hour or two worth of work.
Comment 1 wes hayutin 2010-02-16 12:09:37 EST
mass add of key word FutureFeature to help track
Comment 2 Corey Welton 2010-12-16 08:59:13 EST
Triaged 13-Dec

Note You need to log in before you can comment on or make changes to this bug.