Bug 545226 - postun scriptlet failure in bacula-common during update 3.0.2-4 -> 3.0.3-4
postun scriptlet failure in bacula-common during update 3.0.2-4 -> 3.0.3-4
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bacula (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Thienemann
Fedora Extras Quality Assurance
:
: 542684 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-07 16:51 EST by Felix Schwarz
Modified: 2009-12-17 23:18 EST (History)
5 users (show)

See Also:
Fixed In Version: 3.0.3-5.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-17 23:18:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
console output (1.38 KB, text/plain)
2009-12-07 16:52 EST, Felix Schwarz
no flags Details

  None (edit)
Description Felix Schwarz 2009-12-07 16:51:27 EST
During the update of bacula-{common,client} on F12 (3.0.2-4 -> 3.0.3-4) I experienced a scriptlet failure (command not found).
Comment 1 Felix Schwarz 2009-12-07 16:52:47 EST
Created attachment 376789 [details]
console output
Comment 2 Paul Howarth 2009-12-07 17:23:04 EST
Easy enough to spot what that is:

%postun common
Dropped due to Guidelines
#test "$1" != 0 || /usr/sbin/fedora-userdel  bacula &>/dev/null || :
#test "$1" != 0 || /usr/sbin/fedora-groupdel bacula &>/dev/null || :


The only thing that's not commented out is... a comment!

The whole %postun script should just be removed, along with its fedora-usermgmt dependency:

%package common
...
Requires(postun): fedora-usermgmt
Comment 3 Fedora Update System 2009-12-08 10:03:58 EST
bacula-3.0.3-5.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/bacula-3.0.3-5.fc12
Comment 4 Fedora Update System 2009-12-09 23:22:18 EST
bacula-3.0.3-5.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bacula'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12997
Comment 5 Ondrej Vasik 2009-12-10 08:32:07 EST
*** Bug 542684 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2009-12-17 23:18:36 EST
bacula-3.0.3-5.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.