Bug 545266 - ibus-qt breaks keyboard input into KDE password fields
Summary: ibus-qt breaks keyboard input into KDE password fields
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-qt
Version: 12
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Peng Huang
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-08 00:36 UTC by David
Modified: 2010-06-27 23:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
standard KDE 4 from repos
Last Closed: 2010-06-27 23:38:11 UTC
Type: ---


Attachments (Terms of Use)

Description David 2009-12-08 00:36:32 UTC
Description of problem:
With ibus-qt running, I am unable to enter any text into any KDE password fields.

Version-Release number of selected component (if applicable):
Name        : ibus-qt
Version     : 1.2.0.20091206
Release     : 2.fc12

How reproducible: Always
Steps to Reproduce:
1. Configure KDE to use ibus-qt
2. Log in to KDE
3. Open any password dialog, e.g. KWallet or the screen saver password field
  
Actual results:
Unable to enter any text. Text can be entered into other fields, e.g. Konsole and Kwrite work fine; I can even enter Chinese into these apps.

Expected results:
Able to enter text into password fields. The screen saver password is particularly annoying because there's no way to get back to your desktop other than to kill X.


Additional info:

Comment 1 Peng Huang 2009-12-08 02:37:21 UTC
Did you restart your desktop? Or did update other components? I can not reproduce it on my box with kwalletmanager, or screen saver.

Comment 2 David 2009-12-08 03:14:58 UTC
Yes, fedora-updates sent down some other stuff including a kernel. I rebooted into the new kernel and it still does this. The password fields work if I kill all ibus* processes. After the next time I start ibus the password fields break again.

$ rpm -qa |grep ^ibus |sort
ibus-1.2.0.20091124-1.fc12.x86_64
ibus-anthy-1.2.0.20090917-2.fc12.x86_64
ibus-chewing-1.2.0.20091002-1.fc12.x86_64
ibus-gtk-1.2.0.20091124-1.fc12.x86_64
ibus-hangul-1.2.0.20090617-2.fc12.x86_64
ibus-libs-1.2.0.20091124-1.fc12.x86_64
ibus-m17n-1.2.0.20091120-1.fc12.x86_64
ibus-pinyin-1.2.0.20090915-1.fc12.noarch
ibus-qt-1.2.0.20091206-2.fc12.x86_64
ibus-rawcode-1.2.0.20090703-2.fc12.x86_64

I am using a pretty standard install from fedora/rpmfusion. I think the only package I have from outside those repositories is some truetype fonts.

I am using im-chooser to enable ibus. I assume it generated .xinputrc, which looks like:

XIM=ibus
XIM_PROGRAM="/usr/bin/ibus-daemon"
ICON="/usr/share/icons/hicolor/scalable/apps/ibus.svg"
XIM_ARGS="--xim"
PREFERENCE_PROGRAM=/usr/bin/ibus-setup
SHORT_DESC="IBus"
GTK_IM_MODULE=ibus

if test -f /usr/lib/qt4/plugins/inputmethods/libqtim-ibus.so || \
   test -f /usr/lib64/qt4/plugins/inputmethods/libqtim-ibus.so;
then
    QT_IM_MODULE=ibus
fi

Comment 3 David 2009-12-10 21:19:06 UTC
It appears that this is due to KDE being broken when the "three bullets for each letter" option is enabled for password fields. I guess ibus-qt was just not exposing that flaw as badly before and now it's totally broken by it. Changing the option to one bullet for each password letter removes this issue entirely.

https://bugs.kde.org/show_bug.cgi?id=186724

Comment 4 Peng Huang 2009-12-13 01:47:38 UTC
What is 'three bullets for each letter'? How to enable this option?

Comment 5 David 2009-12-13 05:30:03 UTC
1. Open systemsettings.
2. Under the "General" tab, under the "Personal" heading, click "About Me."
3. On the first page "Password & User Account" of this settings module, at the bottom there are the following choices for "At Password Prompt":

- Show one bullet for each letter <-- this one works
- Show three bullets for each letter <-- this one is now totally broken
- Show nothing

Looks like a KDE bug though, probably not much to do with ibus other than being exposed by it.

Comment 6 Peng Huang 2009-12-15 09:40:25 UTC
Please try the scratch build. I think it could fix your problem.
http://koji.fedoraproject.org/koji/taskinfo?taskID=1872628

Comment 7 Fedora Update System 2009-12-16 06:15:24 UTC
ibus-qt-1.2.0.20091216-1.fc12,ibus-1.2.0.20091215-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ibus-qt-1.2.0.20091216-1.fc12,ibus-1.2.0.20091215-1.fc12

Comment 8 David 2009-12-16 22:03:00 UTC
Yup, KDE still consumes 100% CPU and is slow to respond, but the scratch build allows keystrokes to work as they did before. Thanks!

Comment 9 Fedora Update System 2009-12-18 04:45:38 UTC
ibus-1.2.0.20091215-1.fc12, ibus-qt-1.2.0.20091217-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ibus ibus-qt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13391


Note You need to log in before you can comment on or make changes to this bug.