Bug 545548 - ruby : Violation of the Packaging Guidelines
ruby : Violation of the Packaging Guidelines
Status: CLOSED DUPLICATE of bug 428384
Product: Fedora
Classification: Fedora
Component: ruby (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 428384
  Show dependency treegraph
 
Reported: 2009-12-08 15:42 EST by Michael Schwendt
Modified: 2009-12-09 00:19 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-09 00:19:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2009-12-08 15:42:09 EST
The package doesn't adhere to the guidelines for
packaging static libraries:
https://fedoraproject.org/wiki/Packaging:Guidelines#Packaging_Static_Libraries

The -devel package provides a virtual -static package and contains both
the shared and the static build of a library. That makes it possible to
link staticly with the -devel package as a build requirement instead
of having to build-require the -static package.

Correct would be to split off the static libraries into a separate
-static subpackage.

[...]

ruby-devel provides ruby-libs-static
ruby-1.8.6.383-4.fc13.src.rpm
    /usr/lib/libruby-static.a
    /usr/lib/libruby.so
Comment 1 Mamoru TASAKA 2009-12-09 00:19:38 EST

*** This bug has been marked as a duplicate of bug 428384 ***

Note You need to log in before you can comment on or make changes to this bug.