Bug 545585 - Order of sudoers entries changes at random in sudoers resource
Order of sudoers entries changes at random in sudoers resource
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Configuration (Show other bugs)
unspecified
All Linux
low Severity low (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
: SubBug
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-08 16:43 EST by Steve Salevan
Modified: 2014-05-16 16:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-16 16:11:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Salevan 2009-12-08 16:43:28 EST
Description of problem:
If a user adds multiple records to /etc/sudoers which are detected by the RHQ sudoers resource, the list of records will be randomized upon each click of the "Configure" tab

Version-Release number of selected component (if applicable):
RHQ, linux-config branch, 12/8 git pull

How reproducible:
Always

Steps to Reproduce:
1. Set up an RHQ agent and point it to an RHQ server
2. Edit /etc/sudoers with visudo and add multitudinous valid aliases to it, such as the following:

Cmnd_Alias     PAGERS= /bin/*, /usr/bin/less
rhqadmin  ALL = (ALL) NOPASSWD: PAGERS

Host_Alias     SERVERS = host1,host2
rhqadmin  SERVERS = (ALL) NOPASSWD: ALL

User_Alias     ADMINS = rhqadmin
ADMINS     ALL = (ALL) NOPASSWD: ALL

rhqadmin host1=(ALL)  /bin/*

3. Access the platform corresponding to this machine, access its sudoers resource, and click the Configure tab multiple times
  
Actual results:
Ordering of sudoers entries changes upon each tab click and 'view' button functionality is deterministic (random sudoers entry chosen for editing instead of intended entry)

Expected results:
Ordering of sudoers entries and 'view' button functionality consistent

Additional info:
Comment 1 wes hayutin 2010-02-16 11:57:53 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 2 wes hayutin 2010-02-16 12:02:53 EST
making sure we're not missing any bugs in rhq_triage

Note You need to log in before you can comment on or make changes to this bug.