Bug 545648 - SELinux is preventing /usr/bin/iceauth "read" access on dcopPfMg8b.
Summary: SELinux is preventing /usr/bin/iceauth "read" access on dcopPfMg8b.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:3a1ba7deb15...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-09 02:34 UTC by Daniel Scott
Modified: 2009-12-23 16:10 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-22 20:42:12 UTC
Type: ---


Attachments (Terms of Use)

Description Daniel Scott 2009-12-09 02:34:38 UTC
Summary:

SELinux is preventing /usr/bin/iceauth "read" access on dcopPfMg8b.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by iceauth. It is not expected that this access
is required by iceauth and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:unconfined_r:iceauth_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:user_tmp_t:s0
Target Objects                dcopPfMg8b [ file ]
Source                        iceauth
Source Path                   /usr/bin/iceauth
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           xorg-x11-server-utils-7.4-13.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-55.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31.6-162.fc12.x86_64
                              #1 SMP Fri Dec 4 00:06:26 EST 2009 x86_64 x86_64
Alert Count                   1
First Seen                    Tue 08 Dec 2009 09:33:56 PM EST
Last Seen                     Tue 08 Dec 2009 09:33:56 PM EST
Local ID                      bfac5574-0e48-4663-a94a-5fe104f709c5
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1260326036.244:933): avc:  denied  { read } for  pid=15062 comm="iceauth" name="dcopPfMg8b" dev=dm-5 ino=98695 scontext=unconfined_u:unconfined_r:iceauth_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_tmp_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1260326036.244:933): arch=c000003e syscall=2 success=yes exit=7 a0=7fff3a29a173 a1=0 a2=1b6 a3=0 items=0 ppid=15061 pid=15062 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=23 comm="iceauth" exe="/usr/bin/iceauth" subj=unconfined_u:unconfined_r:iceauth_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-55.fc12,catchall,iceauth,iceauth_t,user_tmp_t,file,read
audit2allow suggests:

#============= iceauth_t ==============
allow iceauth_t user_tmp_t:file read;

Comment 1 Daniel Walsh 2009-12-09 14:20:58 UTC
Could you check

rpm -q selinux-policy-targeted

Comment 2 Daniel Scott 2009-12-09 14:54:08 UTC
I'm not certain, because I can't access that machine at the moment, but I'm pretty sure that it's:

selinux-policy-3.6.32-55.fc12.noarch

It should have downloaded that update early this morning. I can confirm tonight if you need.

Comment 3 Daniel Walsh 2009-12-09 15:29:09 UTC
THe question I have is how are you running as iceauth_t?  The transition from unconfined_t->iceauth_t was removed in updates.

Are you using confined users?

Comment 4 Daniel Scott 2009-12-09 15:39:26 UTC
Nope, no confined users. Unless that was set as the default?

Comment 5 Daniel Walsh 2009-12-09 16:38:42 UTC
0# sesearch -A -t iceauth_t -p transition | grep unconfined
   allow unconfined_execmem_t iceauth_t : process { transition getattr } ; 
   allow unconfined_java_t iceauth_t : process { transition getattr } ; 
   allow unconfined_mono_t iceauth_t : process { transition getattr } ; 


Ok I guess you can get there from java, mono or execmem apps.

I will add the required access.

You can add these rules for now using

# grep avc /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Fixed in selinux-policy-3.6.32-57.fc12.noarch

Comment 6 Fedora Update System 2009-12-16 13:53:04 UTC
selinux-policy-3.6.32-59.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/selinux-policy-3.6.32-59.fc12

Comment 7 Fedora Update System 2009-12-18 04:41:19 UTC
selinux-policy-3.6.32-59.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13384


Note You need to log in before you can comment on or make changes to this bug.