Bug 54566 - tmpwatch generates mail reporting error due to script error
tmpwatch generates mail reporting error due to script error
Status: CLOSED DUPLICATE of bug 47784
Product: Red Hat Linux
Classification: Retired
Component: tmpwatch (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-12 11:38 EDT by bebryant
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-14 20:27:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bebryant 2001-10-12 11:38:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i586)

Description of problem:
Gratuitous mail to root is generated when tmpwatch in run (under anacron)
if certain directories do not exist.  Due to a script error in
/etc/cron.daily/tmpwatch.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Happens when anacron runs in absence of e.g.  "/var/cache/man/X11R6/cat?"
2.
3.
	

Actual Results:  root gets mail listing error.

Expected Results:  should be no error

Additional info:

change the script:

for foo in X11R6/cat?  cat?  local/cat?
do
[ -d /var/cache/man/$foo ] && /usr/sbin/tmp/watch -f 240 
/var/cache/man/$foo

etc. etc.
Comment 1 Michael Schwendt 2001-10-14 20:27:04 EDT
To reporter:

Install this:

  http://www.redhat.com/support/errata/RHBA-2001-104.html
  http://www.redhat.com/apps/support/updates.html

Btw, duplicate of bug #47784 and resolved.

Comment 2 Preston Brown 2001-11-06 12:17:33 EST

*** This bug has been marked as a duplicate of 47784 ***

Note You need to log in before you can comment on or make changes to this bug.