Bug 545698 - Publican creates unnecessary POT files
Publican creates unnecessary POT files
Status: CLOSED NOTABUG
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Michael Hideo
Joshua Wulf
:
Depends On:
Blocks: 1219316
  Show dependency treegraph
 
Reported: 2009-12-09 00:59 EST by Manuel Ospina
Modified: 2015-11-09 19:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1219316 (view as bug list)
Environment:
Last Closed: 2010-01-19 22:14:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manuel Ospina 2009-12-09 00:59:03 EST
Description of problem:
When creating POT/PO files, publican takes all the XML files from en-US/ directory, even those that are not included in the book/article. Those files that are not included in the book (drafts, excluded chapters, etc.) should not produce POT files as they don't need translation.

Version-Release number of selected component (if applicable): 1.3


How reproducible: Always


Steps to Reproduce:
1. Create a draft XML file in en-US
2. publican update_pot
3.
  
Actual results: 
A POT file of the draft XML file is created in the pot directory 


Expected results:
The draft XML file should be ignored when creating the POT files as it doesn't need translation.
Only POT files of those XML files included in a book should be created.


Additional info:
Comment 1 Jeff Fearn 2009-12-09 01:23:01 EST
IMHO this highlights a flaw in the translation work flow and isn't a bug in publican.

You should only be translating files marked for translation. Files that _are_ included in the book may not be ready for translation yet, so relying on whether or not they are currently included in the book is, at best, unreliable.

Furthermore since writers are responsible, or would be in any sane system, for checking in POT files that are ready for translation, they should not be checking in POT files they don't want translated.

Cheers, Jeff.

Note You need to log in before you can comment on or make changes to this bug.