Bug 545702 - /usr/bin/xdg-mime: line 531: kde-config: command not found
Summary: /usr/bin/xdg-mime: line 531: kde-config: command not found
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xdg-utils
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-09 06:18 UTC by Jens Petersen
Modified: 2009-12-28 20:13 UTC (History)
2 users (show)

Fixed In Version: 1.0.2-16.20091217cvs.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-17 19:16:21 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 25563 None None None Never

Description Jens Petersen 2009-12-09 06:18:58 UTC
Description of problem:
xdg-mime seems to output some error messages for its default command.

Version-Release number of selected component (if applicable):
xdg-utils-1.0.2-14.20091016cvs.fc12

How reproducible:
every time

Steps to Reproduce:
1. run: "xdg-mime default gnome-eog.desktop image/png"
  
Actual results:
/usr/bin/xdg-mime: line 531: kde-config: command not found
mkdir: cannot create directory `': No such file or directory
touch: cannot touch `/profilerc': Permission denied
/usr/bin/xdg-mime: line 542: /profilerc.new: Permission denied

Expected results:
intelligible error message or no error

Comment 1 Rex Dieter 2009-12-09 14:09:14 UTC
In GNOME I presume?  (I'll assume that, unless otherwise specfified... for testing/reproducibility)

Comment 2 Jens Petersen 2009-12-10 03:55:04 UTC
Yes sorry in gnome - forgot to mention that.

Comment 3 Rex Dieter 2009-12-10 20:23:19 UTC
OK, found the problem.  

If it makes you feel any better, looks like it's mostly harmless... the mime assocation should be getting set correctly, it's just the attempt to set kde prefs fails ungracefully if the runtime isn't present.

Comment 4 Rex Dieter 2009-12-17 19:10:04 UTC
Fixed upstream, see
https://bugs.freedesktop.org/show_bug.cgi?id=25563#c2

Comment 5 Rex Dieter 2009-12-17 19:16:21 UTC
* Thu Dec 17 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.2-16.20091217cvs
- xdg-mime: line 531: kde-config: command not found (#545702)
- xdg-email calls gconftool which doesn't exist (#548529)

Comment 6 Fedora Update System 2009-12-17 19:50:57 UTC
xdg-utils-1.0.2-16.20091217cvs.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/xdg-utils-1.0.2-16.20091217cvs.fc12

Comment 7 Fedora Update System 2009-12-17 19:58:30 UTC
xdg-utils-1.0.2-16.20091217cvs.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/xdg-utils-1.0.2-16.20091217cvs.fc11

Comment 8 Fedora Update System 2009-12-28 20:10:35 UTC
xdg-utils-1.0.2-16.20091217cvs.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2009-12-28 20:13:29 UTC
xdg-utils-1.0.2-16.20091217cvs.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.