Bug 54572 - generic 2.2.19 kernel install makes ttyS4 invisible to setserial
Summary: generic 2.2.19 kernel install makes ttyS4 invisible to setserial
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: setserial (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-12 17:54 UTC by Need Real Name
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-14 20:04:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-10-12 17:54:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
I use the standard 6.2 install with updates from updates.redhat.com with 
no changes to the MAKEDEV and setserial rpms.
I replaced the standard 6.2 kernel with a generic 2.2.19 kernel from 
kernel.org. Then I tried to reset ttyS4, which my modem uses, using 
setserial and setserial says ttyS4 does not exist. 
I created ttyS4 using MAKEDEV and reset it with chmod and chgrp to 
standard ttyS? settings.
With the standard 6.2 kernel setserial resets ttyS4 every time.
I need the generic kernel to run the MOSIX cluster program.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.remove kernel-source
2.delete 2.2.14-5 directory in /lib/modules, and /usr/src if anything is 
left
3.untar kernel
4.recompile and install kernel
5.reboot
	

Actual Results:  # cd /dev
# ls ttyS4
# ttyS4
# setserial ttyS4
# ttyS4: No such device

Expected Results:  # setserial ttyS4
                   # 

Additional info:

I have done this on 2 different computers with the same result.

Comment 1 Need Real Name 2001-10-14 20:04:09 UTC
/dev/lp0 has also become invisible to setserial, and also to printtool.

Comment 2 Tim Waugh 2001-10-15 11:01:08 UTC
We don't provide the generic kernel; we provide the one the worked.  Closing.
(What was wrong with the Red Hat-provided kernel in the first place?)


Comment 3 Need Real Name 2001-10-17 16:33:06 UTC
The MOSIX cluster program is no longer issued in rpm form. The generic version of MOSIX requires a generic kernel. The rpm kernel 
is unacceptable to the generic MOSIX installer.
I tried the generic kernel because I was under the impression that a generic kernel would work equally well. 
I looked at Piranha. It does not do what I want done. MOSIX does.


Note You need to log in before you can comment on or make changes to this bug.