Bug 54586 - RH 7.1 Failed on install
RH 7.1 Failed on install
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-12 23:25 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-28 13:57:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
saved file upon suggestion from installer (RH 7.1) (9.75 KB, text/plain)
2001-10-12 23:26 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-10-12 23:25:36 EDT
Description of Problem:install would not go beyond selection of root pw.  
Did not creat partitions.  went to reboot and said to mail this file to 
bugzilla.


Version-Release number of selected component (if applicable):


How Reproducible:
tried to install twice - same error

Steps to Reproduce:
1. go as far as root pw selection
2. next
3. error

Actual Results:

would not format drives - errored out and went to reboot
Expected Results:


Additional Information:
	
file saved by installer:

attached
Comment 1 Need Real Name 2001-10-12 23:26:35 EDT
Created attachment 34023 [details]
saved file upon suggestion from installer (RH 7.1)
Comment 2 Brent Fox 2001-10-15 15:17:18 EDT
Can you press <Ctrl><Alt><F4> and see if there are any error messages there?

Comment 3 Need Real Name 2001-10-15 15:33:39 EDT
+------- Additional comments from bfox@redhat.com 2001-10-15 15:17:18
+------- Can you press <Ctrl><Alt><F4> and see if there are any error
+messages there?
+

No I cannot.  This time it errored saying that the partition table was 
corrupted and would not allow me to even get to that drive to partition it at 
all.  Apparantly the first attempt corrupted it.
Comment 4 Brent Fox 2001-10-16 15:34:05 EDT
Can you try booting with 'linux ide=nodma'?  Does that help?

If not, I am inclined to think that something is wrong with the cd.  If you
downloaded the ISO images yourself, did you verify the md5sums of the ISO images
before you burned them?
Comment 5 Need Real Name 2001-10-16 17:53:20 EDT
Yes, and the cd's worked on another system. When the install aborted, the 
partition table was corrupted, so now we have to try to fix that.  Right now, 
it won't even allow me to access the drive from the install to use fdisk.
Comment 6 Brent Fox 2001-10-17 14:34:48 EDT
The first install should not have corrupted the partition table.  The installer
doesn't do anything to the drive until you pass the package selection screen. 
From the look of the traceback, the first traceback occured at the root password
screen, which comes before the package selection screen.
Comment 7 Need Real Name 2001-10-17 17:18:47 EDT
The second or third install attempt got as far as the disk partitioning choices 
and allowed package choices, then quit with the same error.  I'm sorry I didn't 
say that earlier.  Now I cannot even get to the choice to partition the hda 
drive.  It says to either retry or skip the drive.  Retry does not work and 
skip does just that.
Comment 8 Brent Fox 2001-10-18 10:52:21 EDT
Before the crash occurs, try pressing <Ctrl><Alt><F2> and type 'mknod hda' and
then 'fdisk -l hda'.  This should display the current partition table of the
drive.  

If that doesn't work, type 'cat /proc/ide/hda/model' and see if the kernel even
sees the hard drive.  If it doesn't, then the installer has no chance of working.
Comment 9 Brent Fox 2001-10-28 12:44:56 EST
Any more info here?
Comment 10 Need Real Name 2001-10-28 13:57:06 EST
I tried all of that and more.  I finally determined it had to be the mb.  It 
was flakey - at least the controller part.  I replaced the hard drive with a WD 
40 gig and it still had problems, so I replaced the mb.  Even then it took four 
attempts to install RH, but it finally installed.  Now I'm having a hard time 
configuring, but that's because I'm a newbie.  It did not install pop3 for some 
reason so I have to find and install that.  I also can't get it to talk to my 
LAN (again newbie problems), so I can't get on the net with that machine.  If 
you feel kindly toward a newbie maybe you could help?  Routing with RH is not 
easy.

Tks,

Leah
Comment 11 Brent Fox 2001-10-28 18:40:56 EST
Ok.  I'll try to help you out, but I'm marking the bug report closed since the
problem with the installer seems to have gone away with a change in motherboards.

First of all, lets get the network card working.  What kind of network card do
you have?  Attaching the output of 'lspci' to this report would be helpful, so
we can see all the pci devices that the kernel sees.

Note You need to log in before you can comment on or make changes to this bug.