Bug 54589 - New fvwm2 rpm is bad
New fvwm2 rpm is bad
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: fvwm2 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-13 13:19 EDT by Mikhael Goikhman
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-22 04:38:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhael Goikhman 2001-10-13 13:19:05 EDT
I am speaking about the new fvwm2 rpm:
  
http://rpmfind.net//linux/RPM/rawhide/1.0/i386/RedHat/RPMS/fvwm2-2.4.2-1.i386.html

Here is a list of problems with it:

  * datadir is missing (FvwmForm-*, FvwmScript-* and more)
  * fvwm2/fvwm/ directory duplication may be avoided and there are
    2 solutions, one is not to use fvwm2 prefix dir at all and
    another is to specify --disable-package-subdirs

The biggest problem is that this rpm is not compatible with the
official fvwm-themes rpm. The solution is to package fvwm-themes
together with fvwm (or if you insist on that name, fvwm2).

Some links about the official fvwm and fvwm-themes rpms:

  http://fvwm-themes.sourceforge.net/rpm/
  http://www.hpc.uh.edu/fvwm/archive/0108/msg00453.html
  http://rpmfind.net/linux/rpm2html/search.php?query=fvwm
  http://rpmfind.net/linux/rpm2html/search.php?query=fvwm-themes

Regards,
Mikhael.
Comment 1 Mikhael Goikhman 2001-10-13 14:01:10 EDT
More notes.

This rpm is built without support for libstroke so a nice feature is missing
(issue commands and start programs by drawing figures using a mouse).

  http://rpmfind.net/linux/rpm2html/search.php?query=libstroke

On the other hand, there is a support for gnome-libs that is only used in
FvwmGtk module. FvwmGtk may be built as GTK+ application or GNOME application.
It is up to you to decide whether to require GNOME to be installed just for
one FVWM module or not.

Regards,
Mikhael.
Comment 2 Ngo Than 2001-11-05 13:57:42 EST
It's fixed in 2.4.3-2. You find it in next rawhide release.

Note You need to log in before you can comment on or make changes to this bug.