Bug 546032 - iftop does not output in the local character set
iftop does not output in the local character set
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: iftop (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-09 15:33 EST by Matt Castelein
Modified: 2010-04-20 18:18 EDT (History)
1 user (show)

See Also:
Fixed In Version: iftop-0.17-10.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-01 09:29:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Castelein 2009-12-09 15:33:39 EST
Description of problem:
When the local character set is UTF-8, iftop displays in Latin, resulting in junk instead of lines being drawn

Version-Release number of selected component (if applicable):
iftop-0.17-9.fc12.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Local charset UTF-8
2. run iftop
  
Actual results:
Lines drawn as letters instead of lines.

Expected results:
Output looks neat
Comment 1 Robert Scheck 2009-12-13 10:57:18 EST
I've serious issues to reproduce this on a local machine. Is it possible, that
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=419660 describes your issue a
bit more precisely? Or can you please come up with more details?
Comment 2 Robert Scheck 2009-12-13 11:12:16 EST
Looks like what you are describing is bug #192287 for iptraf. Well, I could
relink iftop from curses to cursesw; if you then export NCURSES_NO_UTF8_ACS=1
before starting iftop, the line drawing will match.
Comment 3 Matt Castelein 2009-12-14 10:12:58 EST
(In reply to comment #1)
> I've serious issues to reproduce this on a local machine. Is it possible, that
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=419660 describes your issue a
> bit more precisely? Or can you please come up with more details?  

That's it, that's exactly what I'm talking about.
Comment 4 Robert Scheck 2010-04-01 09:27:38 EDT
I've made a patch which works around the PuTTY issue (doesn't honor vt100
line-drawing when in UTF-8 mode) to get sane lines drawn instead of letters. 
When using PuTTY in UTF-8 mode, you have to execute "NCURSES_NO_UTF8_ACS=1 
iftop" in the future.
Comment 5 Fedora Update System 2010-04-01 09:35:30 EDT
iftop-0.17-10.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/iftop-0.17-10.fc13
Comment 6 Fedora Update System 2010-04-01 09:36:00 EDT
iftop-0.17-10.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/iftop-0.17-10.fc12
Comment 7 Fedora Update System 2010-04-01 09:36:23 EDT
iftop-0.17-10.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/iftop-0.17-10.fc11
Comment 8 Fedora Update System 2010-04-01 09:36:56 EDT
iftop-0.17-10.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/iftop-0.17-10.el5
Comment 9 Fedora Update System 2010-04-01 09:37:20 EDT
iftop-0.17-10.el4 has been submitted as an update for Fedora EPEL 4.
http://admin.fedoraproject.org/updates/iftop-0.17-10.el4
Comment 10 Fedora Update System 2010-04-14 23:13:34 EDT
iftop-0.17-10.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2010-04-14 23:14:33 EDT
iftop-0.17-10.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2010-04-14 23:15:03 EDT
iftop-0.17-10.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2010-04-20 18:18:02 EDT
iftop-0.17-10.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2010-04-20 18:18:32 EDT
iftop-0.17-10.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.