Bug 546049 - Release notes do not mention that ABRT grabs core files
Release notes do not mention that ABRT grabs core files
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
All Linux
low Severity medium
: ---
: ---
Assigned To: John J. McDonough
Karsten Wade
http://docs.fedoraproject.org/release...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-09 16:37 EST by Josh Cogliati
Modified: 2010-10-29 07:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-29 07:07:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Cogliati 2009-12-09 16:37:03 EST
Description of problem:
Basically, if you are trying to debug a program, it is useful to be able to find the core file.  ABRT grabs core files and store them in /var/cache/abrt
The release notes make no mention of this.  

Version-Release number of selected component (if applicable):
0.11 Fri 20 Nov 2009 John McDonough

How reproducible:
Very.

Steps to Reproduce:
1. Create a program that causes a seg fault.
2. Compile program.
3. Run program.
4. Read Segmentation fault (core dumped)
5. Look for core dump.  Hm.  Not in current directory.
6. Look at release notes.  
  
Actual results:
4.1.3. ABRT
The ABRT automatic bug reporting tool replaces bug-buddy and kerneloops in the Fedora 12 desktop. ABRT has an extensible architecture and can not only catch and report segmentation faults and kernel oops, but also python backtraces. In contrast to bug-buddy, it can catch segmentation faults in any binary, not just GTK+ applications.
If you have manually modified the GConf settings for the bug-buddy GTK+ module before, you may see warning messages like the following from GTK+ applications:

Gtk-Message: Failed to load module "gnomebreakpad":
libgnomebreakpad.so: cannot open shared object file: No such file or directory

To stop these messages, run the following command in a terminal in your session:

gconftool-2 --type bool --set /apps/gnome_settings_daemon/gtk-modules/gnomebreakpad false


Expected results:
4.1.3. ABRT
The ABRT automatic bug reporting tool replaces bug-buddy and kerneloops in the Fedora 12 desktop. ABRT has an extensible architecture and can not only catch and report segmentation faults and kernel oops, but also python backtraces. In contrast to bug-buddy, it can catch segmentation faults in any binary, not just GTK+ applications.
If you have manually modified the GConf settings for the bug-buddy GTK+ module before, you may see warning messages like the following from GTK+ applications:

Gtk-Message: Failed to load module "gnomebreakpad":
libgnomebreakpad.so: cannot open shared object file: No such file or directory

To stop these messages, run the following command in a terminal in your session:

gconftool-2 --type bool --set /apps/gnome_settings_daemon/gtk-modules/gnomebreakpad false

The ABRT tool captures debug information (including coredumps) in the directory /var/cache/abrt.  


Additional info:
This may arguably be a bug in ABRT as well since a coredump from a non-system executable (i.e. something where  rpm -qf ../foo reports 
file /home/username/foo is not owned by any package) is not something that should be ABRT should be doing anything special with.
Comment 1 John J. McDonough 2010-02-04 10:09:20 EST
Corrected commit 74dcb3f7e0ed05680275620fe9634d1b31472f40

Note You need to log in before you can comment on or make changes to this bug.