Bug 546071 - Repositories created via CP View don't appear in Repos list
Summary: Repositories created via CP View don't appear in Repos list
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: RHQ Project
Classification: Other
Component: Content
Version: unspecified
Hardware: All
OS: Linux
low
medium vote
Target Milestone: ---
: ---
Assignee: Jay Dobies
QA Contact:
URL:
Whiteboard: sprint_3
Depends On:
Blocks: RHQ_CONT_REPO
TreeView+ depends on / blocked
 
Reported: 2009-12-09 22:20 UTC by Corey Welton
Modified: 2010-03-29 18:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-29 18:23:57 UTC


Attachments (Terms of Use)

Description Corey Welton 2009-12-09 22:20:31 UTC
Description of problem:
This may well be an invalid path - in which case we need to disable its functionality.  Regardless, as it currently exists, user is given option to associate a repo from within a CP's view, but those associated repos do not appear on the global Repo view.


Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1. Administration > Content > Content Provider -- create an RHN CP.
2. After creation, click the newly-created CP's name on the global CP view page.
3.  Scroll down to "Repositories you can synchronize from this Content Provider" section
4. Click the name of one of the Repos, i.e., "rhel-i386-as-3"
5. On the resulting Repo page, section "Content Providers Associated With This Repository", check the box next to your RHN CP, and hit the "Associate" Button.
6. Administration > Content > Repositories -- Look for your newly created/associated repo.


Actual results:

Nothing shows up.  The Repo is still saved in the system.... somewhere... i.e., it is apparently granted a resource id.  But unless you know the URL it will never show up -- you can not get to it from within the CP's "Repositories Associated With This Content Provider" section, either.

As I mentioned in the beginning of this bug, this may well not be a route the user is supposed to be able to go down, vis a vis "Administration > Content > Repositories > Import > ...".  However user can currently do so, and as such is able to enter phantom data into the db.


Expected results:
* Either fix repo creation via this method to allow proper repo imports, or disable this code path.


Additional info:

Comment 1 Jay Dobies 2010-02-08 20:15:56 UTC
This has to do with the fact that the Admin > Content > Repos display only shows non-candidate repos. The table showing "repos that can be imported" shouldn't allow clicking through to the repo view; that view should only be allowed after the repo is imported. I'm going to remove that table entirely, since it actually never led to a place where the import could be done.

Comment 2 Jay Dobies 2010-02-08 20:26:18 UTC
Commit 7f269661c89191172411f05daedbdcadadc09374

The repo table contained links into the repos themselves, which shouldn't be available until the repo is imported. Even when the table was present, there was no import link available on the link destinations.

Comment 3 Mike McCune 2010-02-12 22:16:03 UTC
I'm also going to take away the Edit and Synchronize buttons on the candidate repo details page.

Comment 4 Mike McCune 2010-02-12 22:40:12 UTC
commit d9a2be45a50ed7d53b3a4a72fa7dcb635bea358b
Author: Mike McCune <mmccune@gibson.pdx.redhat.com>
Date:   Fri Feb 12 14:39:39 2010 -0800

    546071 - dont show sync/edit buttons for candidate repos

Comment 5 Corey Welton 2010-03-29 17:32:26 UTC
Mass-move to ON_QA

Comment 6 Corey Welton 2010-03-29 18:23:57 UTC
QA Closing, essentially untestable.


Note You need to log in before you can comment on or make changes to this bug.