Bug 546130 - publican lang_stats counts fuzzy unmatched strings as fuzzy
publican lang_stats counts fuzzy unmatched strings as fuzzy
Status: CLOSED ERRATA
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-09 23:53 EST by Ruediger Landmann
Modified: 2010-11-23 23:16 EST (History)
5 users (show)

See Also:
Fixed In Version: 1.4-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-31 20:14:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PO file for Publican Document Conventions in Assamese (26.88 KB, text/plain)
2009-12-09 23:53 EST, Ruediger Landmann
no flags Details

  None (edit)
Description Ruediger Landmann 2009-12-09 23:53:05 EST
Created attachment 377377 [details]
PO file for Publican Document Conventions in Assamese

Description of problem:
PO files sometimes contain unmatched strings at the end of the file. These are commented out with a #~  at the start of each line.

At some point before being relegated to "unmatched" and commented out, strings might have been marked "fuzzy". When they are commented out as unmatched, they retain their fuzzy tags. 

Running "publican lang_stats" over a PO file that has fuzzies amongst its unmatched strings results in Publican counting these fuzzy strings in its report. 

This is unexpected behaviour because other translation tools do not count fuzzies if they are unmatched (msgfmt, gtranslator, lokalize).

Version-Release number of selected component (if applicable):
Publican 1.3

How reproducible:
100%

Steps to Reproduce:
1. run publican lang_stats over a PO file that has unmatched fuzzy strings in it, but no other fuzzy strings (example attached)

Actual results:
Publican reports fuzzies present in the PO file.

Expected results:
Publican reports no fuzzies.

Additional info:
Comment 1 Jeff Fearn 2009-12-10 00:27:23 EST
Added check for obsolete in lang_stats code.
Comment 2 Fedora Update System 2010-01-28 21:04:43 EST
publican-1.4-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-1.4-1.fc12
Comment 3 Fedora Update System 2010-01-28 21:06:03 EST
publican-1.4-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/publican-1.4-1.fc11
Comment 4 Fedora Update System 2010-01-31 20:12:47 EST
publican-1.4-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2010-01-31 20:21:11 EST
publican-1.4-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.