Bug 546141 - [abrt] crash detected in Miro-2.5.3-3.fc13
Summary: [abrt] crash detected in Miro-2.5.3-3.fc13
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Miro
Version: rawhide
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Alex Lancaster
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3c6c1e27
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-10 06:14 UTC by Itamar Reis Peixoto
Modified: 2010-05-15 20:43 UTC (History)
14 users (show)

Fixed In Version: Miro-3.0.1-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-15 20:18:40 UTC


Attachments (Terms of Use)
File: backtrace (754 bytes, text/plain)
2009-12-10 06:14 UTC, Itamar Reis Peixoto
no flags Details
Selection of Video entry in sidebar to cause the crash (18.36 KB, image/png)
2010-04-20 11:21 UTC, Raphael Groner
no flags Details

Description Itamar Reis Peixoto 2009-12-10 06:14:22 UTC
abrt 1.0.0 detected a crash.

backtrace
-----
Summary: TB3c6c1e27 wrappermap.py:46:wrapper:KeyError: 'Widget wrapper no longer exists'

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/miro/frontends/widgets/gtk/weakconnect.py", line 49, in handle_callback
    return real_method(obj, *(args + self.user_args))
  File "/usr/lib/python2.6/site-packages/miro/frontends/widgets/gtk/base.py", line 90, in on_hierarchy_changed
    window = wrappermap.wrapper(toplevel)
  File "/usr/lib/python2.6/site-packages/miro/frontends/widgets/gtk/wrappermap.py", line 46, in wrapper
    raise KeyError("Widget wrapper no longer exists")
KeyError: 'Widget wrapper no longer exists'

Local variables in innermost frame:
gtk_widget: <gtk.Window object at 0x9d3bf04 (GtkWindow at 0x9ceec28)>

cmdline: /usr/bin/python /usr/bin/miro.real 
component: Miro
executable: /usr/bin/miro.real
kernel: 2.6.31.6-158.fc12.i686
package: Miro-2.5.3-3.fc13
uuid: 3c6c1e27

Comment 1 Itamar Reis Peixoto 2009-12-10 06:14:24 UTC
Created attachment 377383 [details]
File: backtrace

Comment 2 Itamar Reis Peixoto 2009-12-10 06:16:59 UTC
crash when trying to access the page about "the simpsons"

Comment 3 Fedora Update System 2009-12-18 05:38:52 UTC
Miro-2.5.4-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/Miro-2.5.4-1.fc12

Comment 4 Alex Lancaster 2009-12-18 05:42:19 UTC
This update to 2.5.4 may fix this.  Please provide feedback via bodhi on the updates link above.

Comment 5 Fedora Update System 2009-12-22 04:47:01 UTC
Miro-2.5.4-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Miro'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13456

Comment 6 Fedora Update System 2010-01-02 03:31:08 UTC
Miro-2.5.4-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Raphael Groner 2010-04-18 20:33:59 UTC
Problem seems to happen with version 3.0.1 in rawhide again ...

Comment 8 Alex Lancaster 2010-04-19 07:05:30 UTC
(In reply to comment #7)
> Problem seems to happen with version 3.0.1 in rawhide again ...    

Miro on rawhide is still at 3.0, not yet 3.0.1.  

You'll need to describe exactly what the problem is and provide us with a reproducible recipe for duplicating the bug in order to fix it.

Comment 9 Alex Lancaster 2010-04-19 07:12:06 UTC
Also is your stack trace identical (or at least very similar to) the original one posted in comment #0?  There are lot of Miro bugs with different stack traces here.

Comment 10 Raphael Groner 2010-04-19 09:23:50 UTC
Sorry, I got confused with the build system having 3.0.1 and 3.0.2 already.


Count: 1
DUPHASH: 3c6c1e27
DumpDir: /var/cache/abrt/pyhook-1271668656-23091
InformAll: 0
Reported: 0
UUID: 3c6c1e27
analyzer: Python
architecture: x86_64
cmdline: /usr/bin/python /usr/bin/miro.real
component: Miro
executable: /usr/bin/miro.real
kernel: 2.6.33.2-41.fc13.x86_64
package: Miro-3.0-1.fc13
reason: wrappermap.py:46:wrapper:KeyError: 'Widget wrapper no longer exists'
release: Fedora release 13 (Goddard)
time: 1271668656
uid: 500

backtrace
-----
wrappermap.py:46:wrapper:KeyError: 'Widget wrapper no longer exists'

Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/miro/frontends/widgets/gtk/weakconnect.py", line 49, in handle_callback
    return real_method(obj, *(args + self.user_args))
  File "/usr/lib64/python2.6/site-packages/miro/frontends/widgets/gtk/base.py", line 90, in on_hierarchy_changed
    window = wrappermap.wrapper(toplevel)
  File "/usr/lib64/python2.6/site-packages/miro/frontends/widgets/gtk/wrappermap.py", line 46, in wrapper
    raise KeyError("Widget wrapper no longer exists")
KeyError: 'Widget wrapper no longer exists'

Local variables in innermost frame:
gtk_widget: <gtk.Window object at 0x7f876c1c7190 (GtkWindow at 0x22bccd0)>

description
-----
Miro - Internet TV Player

Miro is a free application that turns your computer into an
internet TV video player. This release is still a beta version, which means
that there are some bugs, but we're moving quickly to fix them and will be
releasing bug fixes on a regular basis.

reproduce
-----
1. click in Miro left sidebar on "Video" to see list with all stored videos
2.
3.

Comment 11 Raphael Groner 2010-04-19 09:33:12 UTC
abrt told me that it is the same bug when i tried to post the report, so I did not thought to provide all infos again.

Comment 12 Insang Ryu 2010-04-20 00:33:05 UTC
Package: Miro-3.0-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. sorry I don't know what crash is this.
2.
3.

Comment 13 Raphael Groner 2010-04-20 11:19:45 UTC
(In reply to comment #12)
> 1. sorry I don't know what crash is this.

Please look at the attachment. The selection is marked there.

Comment 14 Raphael Groner 2010-04-20 11:21:12 UTC
Created attachment 407792 [details]
Selection of Video entry in sidebar to cause the crash

Comment 15 Carl G. 2010-04-25 07:14:34 UTC
Package:    	Miro-3.0-1.fc13
Latest Crash:	Sun 25 Apr 2010 03:07:47 AM 
Command:    	/usr/bin/python /usr/bin/miro.real
Reason:     	wrappermap.py:46:wrapper:KeyError: 'Widget wrapper no longer exist

x64

wrappermap.py:46:wrapper:KeyError: 'Widget wrapper no longer exists'

Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/miro/frontends/widgets/gtk/weakconnect.py", line 49, in handle_callback
    return real_method(obj, *(args + self.user_args))
  File "/usr/lib64/python2.6/site-packages/miro/frontends/widgets/gtk/base.py", line 90, in on_hierarchy_changed
    window = wrappermap.wrapper(toplevel)
  File "/usr/lib64/python2.6/site-packages/miro/frontends/widgets/gtk/wrappermap.py", line 46, in wrapper
    raise KeyError("Widget wrapper no longer exists")
KeyError: 'Widget wrapper no longer exists'

Local variables in innermost frame:
gtk_widget: <gtk.Window object at 0x4611d20 (GtkWindow at 0x43ec710)>

Comment 16 Alex Lancaster 2010-04-25 09:48:35 UTC
Will: any idea what's going on here?  Seems the problem is still in 3.0.x

Comment 17 Raphael Groner 2010-04-25 10:05:07 UTC
It happens here on x86_64 platform.

Reproducable on two different machines with both running Fedora rawhide.

Comment 18 Raphael Groner 2010-04-25 11:24:26 UTC
This crash does not affect stability of miro. It is due to a bug in xulrunner in background.

Take a look here for a possible fix:
https://bugs.launchpad.net/ubuntu/+source/miro/+bug/537050

So either update xulrunner in the package dependency or apply the provided patch.

Comment 19 Felix Möller 2010-04-25 19:09:14 UTC
Package: Miro-3.0-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
open miro and click on any of the menu entries on the left side ...

Comment 20 will kahn-greene 2010-04-26 13:21:56 UTC
(In reply to comment #16)
> Will: any idea what's going on here?  Seems the problem is still in 3.0.x    

The problem is that XULRunn 1.9.2 has some change in it that causes Miro to error and kick up the stack trace in comment #15 (and other comments), or it causes Miro to crash.

This affects all versions of Miro--it's not just the 2.5 series or the 3 series.

Launchpad has this as bug 537050:

   https://bugs.launchpad.net/ubuntu/+source/miro/+bug/537050

In the Miro bug tracker, this is bug 13169:

   http://bugzilla.pculture.org/show_bug.cgi?id=13169

Ben worked out two patches both of which should work.  One of them overrides the do_realize and do_unrealize methods of MozEmbed.  We think this one is a bit sketchy since we didn't spend enough time figuring out exactly what those methods are doing in MozEmbed other than causing the problem.

The second patch fixes the Miro setup.py file to force Miro to build against and use XULRunner 1.9.1 where everything works fine.

In Ubuntu Lucid, they dropped the XULRunner 1.9.1 packages, so the Miro package in the Ubuntu repositories and the one that I generated both use the first patch (do_(un)realize overriding).

We spent a week looking into this and working out possibilities.  It's hard to justify spending more time on it.  We're looking at ditching gtkmozembed and either implementing our own XPCOM bits (like we do for Miro on Windows) or we'll do something else.  That work is targeted for Miro 3.1.

I think that covers everything.

Comment 21 Raphael Groner 2010-04-26 15:53:56 UTC
(In reply to comment #20)
Will, thanks for your detailed answer. :o)

In my opinion, it is better to have a workaround in the application than to wait (maybe forever) for a general fix, that will break something else then.

Comment 22 Konstantin Ryabitsev 2010-04-27 19:09:42 UTC
Package: Miro-3.0-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


Comment
-----
Just starting Miro.

Comment 23 Fedora Update System 2010-05-05 23:45:56 UTC
Miro-3.0.1-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/Miro-3.0.1-1.fc13

Comment 24 Fedora Update System 2010-05-06 00:03:38 UTC
Miro-3.0.1-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/Miro-3.0.1-1.fc12

Comment 25 Fedora Update System 2010-05-06 06:56:14 UTC
Miro-3.0.1-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Miro'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/Miro-3.0.1-1.fc13

Comment 26 Raphael Groner 2010-05-06 16:47:56 UTC
(In reply to comment #25)
I still have the problem with Miro-3.0.1-1.fc13 installed from link of comment #23, assuming that nothing changed in the package while entering the repository.

It is no good idea (in my opinion) to wait for Miro 3.1 release to have this bug fixed. All users will have to live with the mentioned error message until then.

Comment 27 will kahn-greene 2010-05-06 17:21:21 UTC
(In reply to comment #26)
> (In reply to comment #25)
> I still have the problem with Miro-3.0.1-1.fc13 installed from link of comment
> #23, assuming that nothing changed in the package while entering the
> repository.
> 
> It is no good idea (in my opinion) to wait for Miro 3.1 release to have this
> bug fixed. All users will have to live with the mentioned error message until
> then.    

I think you misunderstood.  We (PCF) are working on a better fix for Miro 3.1, but have two patches that can be applied that fix the issue but in hacky ways.

When you say you're having the same problem, are you sure it's the same exact issue?  What's in your miro.log file?

Comment 28 Felix Möller 2010-05-06 18:25:43 UTC
For me the update fixed the problem.

Comment 29 Michel Alexandre Salim 2010-05-07 00:56:10 UTC
(In reply to comment #26)
> (In reply to comment #25)
> I still have the problem with Miro-3.0.1-1.fc13 installed from link of comment
> #23, assuming that nothing changed in the package while entering the
> repository.
> 
Did you restart Miro? That build has the stopgap patch applied. I managed to reproduce your problem with our builds of Miro 3.0 and below but not with 3.0.1.

Also, nobody has commented on this, but Fedora packages are named Name-Version-Releaase -- please don't confuse 3.0-1, 3.0-2 with 3.0.1 and 3.0.2

Comment 30 Fedora Update System 2010-05-07 03:51:07 UTC
Miro-3.0.1-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update Miro'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/Miro-3.0.1-1.fc12

Comment 31 Raphael Groner 2010-05-07 10:21:56 UTC
Okay, I got actually confused by the versioning and yum did not suggest me the update to apply for some reason - maybe package cache was not updated. 
@Michel: Thanks for the hint.

So, it works for me now, also. Sorry for any inconvenience.

Comment 32 Fedora Update System 2010-05-15 20:18:01 UTC
Miro-3.0.1-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 33 Fedora Update System 2010-05-15 20:43:04 UTC
Miro-3.0.1-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.