Bug 54624 - stat truncates large files' size
Summary: stat truncates large files' size
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: stat   
(Show other bugs)
Version: 7.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-13 23:15 UTC by Ben LaHaise
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-17 17:21:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben LaHaise 2001-10-13 23:15:47 UTC
Use of stat on large (>2GB) files leads to misleading results being 
printed.  This appears to be caused by truncating the 64 bit length used 
in LFS to 32 bits when printing.  See below.  This bug is in 7.*

[root@toomuch root]# ls -l /bcrl/sda6_6.2.bak 
-rw-rw-r--    1 bcrl     cygnus   4894007296 Dec  6  2000 
/bcrl/sda6_6.2.bak
[root@toomuch root]# stat /bcrl/sda6_6.2.bak 
  File: "/bcrl/sda6_6.2.bak"
  Size: 599040000       Blocks: 9567968    IO Block: 4096   Regular File
Device: 806h/2054d      Inode: 32780       Links: 1    
Access: (0664/-rw-rw-r--)  Uid: (  621/    bcrl)   Gid: ( 1002/  cygnus)
Access: Wed Dec  6 12:44:43 2000
Modify: Wed Dec  6 12:48:05 2000
Change: Mon Aug 13 14:45:03 2001

[root@toomuch root]#

Comment 1 Ngo Than 2001-10-16 23:40:15 UTC
please try stat-2.5-2 in 7.2. It should fix this problem.

Comment 2 Ben LaHaise 2001-10-17 17:21:37 UTC
I said all releases.  This includes 7.2 with stat 2.5-2.

Comment 3 Ngo Than 2001-10-17 23:03:43 UTC
It's fixed in stat-2.5-3. You will find it in rawhide


Note You need to log in before you can comment on or make changes to this bug.