Bug 54631 - /etc/rc.d/init.d/xfs start when run twice starts two font servers
/etc/rc.d/init.d/xfs start when run twice starts two font servers
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i586 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-14 06:23 EDT by George Pajari
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-21 06:50:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Pajari 2001-10-14 06:23:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows 98; Win 9x 4.90)

Description of problem:
The X11Free86-xfs Font Server initscript if run twice will start two font 
servers. Since they listen on the same port there is no point is 
permitting two font servers to run.

The Linux Standard Base (LSB 1.0.0) states "Init files should ensure that 
they will behave sensibly if invoked with start when the service is 
already running...".

It would therefore be appropriate for an "xfs start" to be a noop if xfs 
is already running.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1./etc/rc.d/init.d/xfs start
2./etc/rc.d/init.d/xfs start
3./etc/rc.d/init.d/xfs status
	

Actual Results:  Two font servers running.

Expected Results:  One font server running.

Additional info:
Comment 1 Mike A. Harris 2002-12-21 06:50:30 EST
I haven't confirmed this on Red Hat Linux 7.1, however it is working ok
in Red Hat Linux 8.0 with rawhide XFree86 installed currently.  Here is
my test session below:

[root@claw root]# killall -9 xfs
xfs: no process killed
[root@claw root]# service xfs start
Starting xfs:                                              [  OK  ]
[root@claw root]# service xfs start
Starting xfs:
[root@claw root]# ps ax | grep [x]fs
15911 ?        S      0:00 xfs -droppriv -daemon

Only one copy of xfs running.

While I haven't specifically confirmed the problem in 7.1, since it isn't
reproduceable in the current codebase, I'm treating this one as resolved
in RAWHIDE now and closing.  Also note that Red Hat Linux 7.3 plus erratum
and Red Hat Linux 8.0 are both LSB certified so this is most likely not
present in 7.3 or 8.0 stock either.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.