Bug 54635 - Redraw triggers graph scrolling
Redraw triggers graph scrolling
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: xosview (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-14 16:48 EDT by Craig Lawson
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-14 16:48:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Craig Lawson 2001-10-14 16:48:03 EDT
Description of Problem:
  Forcing the xosview window to redraw triggers the scrolling graphs to
scroll. The extra scrolling makes the graphs inaccurate. For example, if
the CPU graph is configured to to scroll once every two seconds, then 60
redraw events can cause the graph to represent that 120 seconds have
passed, when in fact only one or two actual seconds may have elapsed.

Version-Release number of selected component (if applicable):
1.7.3, release 4

How Reproducible:
100%

Steps to Reproduce:
1. Add the following to your .Xdefaults, or pass as -xrm arguments on the
command line:
    xosview*cpu: true
    xosview*cpuGraph: true
    xosview*cpuPriority: 20
2. Start xosview.
3. Open another window. A terminal window will do. Grab the terminal window
with your mouse, and move it around the screen. Pass it over the xosview
window to send redraw events to xosview. While it partially covers xosview,
wiggle it a lot to generate a lot of events.

Actual Results:
The CPU graph scrolls with haste while it processes the redraw events.

Expected Results:
The CPU graph should update only once every two seconds.
Comment 1 Ngo Than 2001-10-16 12:04:02 EDT
cannot reproduce it here. the CPU graph updates correct only once every two seconds.


Note You need to log in before you can comment on or make changes to this bug.