Bug 54637 - atalkd gets suspended during boot with newest SysVinit
atalkd gets suspended during boot with newest SysVinit
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: SysVinit (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-14 18:06 EDT by Jonathan Kamens
Modified: 2014-03-16 22:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-22 08:33:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2001-10-14 18:06:24 EDT
I upgraded from SysVinit-2.78-19 to SysVinit-2.79-1.  Now, when I reboot my
machine, atalkd gets a suspend signal at some point during the reboot
process, i.e., after I reboot, atalkd is in state "T" according to ps, and
none of the other processes that should have been started during "service
atalk start" are running.  (Atalkd is part of the netatalk package from
powertools.)

Note that the atalk startup script is special in that it starts up atalkd,
etc. in the background because they're slow to start up.

Reverting to SysVinit-2.78-19 made the problem go away, so there's cearlly
something fishy with SysVinit, regardless of whether you're continuing to
support netatalk (and even if you aren't, it's a useful test case for
reproducing the problem in SysVinit).

It may be relevant that atalk is started near the end of the boot process,
so it isn't finished launching all the atalk processes before the boot
process finishes.
Comment 1 Jonathan Kamens 2001-11-12 07:59:17 EST
This is still broken in 2.79-2.
Comment 2 Bill Nottingham 2002-07-18 21:47:34 EDT
This got fixed with 2.84-x, yes?
Comment 3 Jonathan Kamens 2002-07-22 08:33:11 EDT
Yes, it appears to be fixed in 2.84-5, although I can't say exactly when it was
fixed since I had modified my atalk configuration to start the daemons in the
foreground to avoid this problem (i.e., I don't know whether it's fixed in Limbo).
Comment 4 Bill Nottingham 2002-07-22 13:25:12 EDT
Yeah, 2.79 showed various brokenness; that's why we didn't end up shipping it.
Apologies for the delay.

Note You need to log in before you can comment on or make changes to this bug.