This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 54642 - openssh-2.9p2-8.7 does not handle IPv6 correctly in some respects
openssh-2.9p2-8.7 does not handle IPv6 correctly in some respects
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-15 03:58 EDT by Per Steinar Iversen
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-17 17:57:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Per Steinar Iversen 2001-10-15 03:58:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010913

Description of problem:
openssh-2.9p2-8.7 does not allow access over IPv6 when there is a
tcp_wrapper type access control in /etc/hosts.allow based on domain.

This will work:

sshd: ALL
sshdfwd-X11: ALL

This fails:

sshd: .hio.no
sshdfwd-X11: .hio.no

The following is logged in this case:

refused connect from 0.0.0.0

Both the server and client have proper AAAA records and corresponding
entries in ip6.int


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Upgrade to openssh-2.9p2-8.7  This adds IPv6 support also to openssh.
2. If anything but ALL access is defined in /etc/hosts.allow access fails.
3.

Actual Results:  Access is denied.

Expected Results:  Access allowed.

Additional info:

This problem is probably because the part of openssh that reads
/etc/hosts.allow does not understand IPv6, AAAA records etc.
Comment 1 Pekka Savola 2002-01-17 17:57:45 EST
You need to rebuild openssh with updated tcp_wrappers (they were present only from RHL72 onwards) if you want
IPv6 connections to work.
Comment 2 Nalin Dahyabhai 2002-03-07 15:46:44 EST
Closing as fixed in Raw Hide.

Note You need to log in before you can comment on or make changes to this bug.