This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 546488 - Publican breaks on string with ampersand and semi-colon (&string;)
Publican breaks on string with ampersand and semi-colon (&string;)
Status: CLOSED DUPLICATE of bug 545334
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-10 20:05 EST by Deon Ballard
Modified: 2010-11-23 23:18 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-10 20:33:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Deon Ballard 2009-12-10 20:05:27 EST
I have a string in a code example which should be, literally:

&attribute_change;

I have tried replacing the ampersand with & and with & and the semi-colon with &#059;. However, when publican runs, it substitutes the characters and then errors out, claiming it can't find entity &attribute_change;.

The file is http://svn.devel.redhat.com/cgi-bin/viewvc.cgi/ecs/Red_Hat_Directory_Server/9.0/plugin/en-US/Data_Type_and_Structure_Reference.xml?view=log line 363, if that's necessary.

The exact error message is:
Beginning work on en-US
Data_Type_and_Structure_Reference.xml:389: parser error : Entity 'attribute_change' not defined
list_of_attrs[0] = &attribute_change;
                                   ^
The version of publican is, I believe, 1.0.

I think the solution needs to be something that allows me to use the proper string in the code example. Maybe a way to escape those characters?
Comment 1 Jeff Fearn 2009-12-10 20:33:49 EST

*** This bug has been marked as a duplicate of bug 545334 ***

Note You need to log in before you can comment on or make changes to this bug.