This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 5466 - "Escape" Key not mapped on Dell Inspiron 7000 Virgin Installation
"Escape" Key not mapped on Dell Inspiron 7000 Virgin Installation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-01 09:53 EDT by daltonm
Modified: 2015-01-07 18:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-08 09:12:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description daltonm 1999-10-01 09:53:25 EDT
After a virgin installation (not an upgrade) on a Dell
Inspiron 7000 laptop, the "Escape" key is rejected, with a
beep from the console and a flash from an xterm.  This
prevents the use of any key sequence that includes "Escape"
key such as "Escape-K" which should activate command
recall/editting from bash shell (set -o vi mode).  At first,
I though this might've been a bash shell change since Redhat
5.2 (installed on another, different system) but I've been
unable to find anything that would alter the use of the
"Escape" key within the bash shell documentation that I
have.  Definitely, it's not something that I did
intentionally.

I've checked the Keytable startup script in /etc/rc.d/init.d
and /etc/sysconfig/keyboard and they both appear correct.
My /etc/sysconfig/keyboard contents are:

KEYTABLE="us"

In addition, my /var/log/messages confirms that "keytable"
is doing something and appears to be correct:

Oct  1 07:58:28 vger keytable: Loading keymap:
Oct  1 07:58:28 vger keytable: Loading
/usr/lib/kbd/keymaps/i386/qwerty/us.kmap.gz
Oct  1 07:58:28 vger keytable: Loading system font:
Oct  1 07:58:29 vger rc: Starting keytable succeeded

I suspect something is not right about this keymap but I
don't understand what it might be.  The reason I suspect
this is that, right now, I'm using a docking station with an
external monitor, keyboard, and mouse and the error is the
same with this configuration as it is with the native
keyboard on the Dell Inspiron 7000.

I've successfully applied all of the Errata packages
currently documented, omitting a couple because I don't have
the corresponding package installed, starting first with the
RPM 3.0.2 package.

At this point, I don't know what to do but I really miss
command recall/editting and it's starting to really annoy
me.  Can anyone help me sort this one out, please?  Thanks!

------- Additional Comments From   10/03/99 14:12 -------
It seems that vim recognizes the "Escape" key.  Now I'm really
confused!

------- Additional Comments From   10/03/99 18:36 -------
I've figure out what's causing the problem and have a work-around.  I
put two and two together and came up with readline, something that I
have only a passing knowledge of.  The bash shell uses readline for
command line editting so I had to figure out what influences readline
behavior.  It turns out that if INPUTRC environment variable is set,
readline will use whatever is set there.

In RedHat 6.0, environment variable INPUTRC is set to "/etc/inputrc"
which has this contents:

set meta-flag on
set input-meta on
set convert-meta off
set output-meta on
"\e0d": backward-word
"\e0c": forward-word
"\e[h": beginning-of-line
"\e[f": end-of-line
"\e[1~": beginning-of-line
"\e[4~": end-of-line
"\e[5~": beginning-of-history
"\e[6~": end-of-history
"\e[3~": delete-char
"\e[2~": quoted-insert

I checked on a RedHat 5.2 system (my other system that doesn't exhibit
the malfunction) and noticed that environment variable INPUTRC is not
set by default.  So, I traced back to what might be setting it.  It's
set in "/etc/profile" in RedHat 6.0 but not set there in RedHat 5.2.
When I commented that setting out of my RedHat 6.0 "/etc/profile" and
rebooted, the problem went away.  It seems that whatever is in
"/etc/inputrc" traps the "Escape" key as far as readline is concerned.

I leave up to you folks to figure out the right thing to do.  For my
money, not setting INPUTRC (like in RedHat 5.2) would be the thing to
do.  If anybody knows what exactly is being done in the RedHat 6.0
version of "/etc/inputrc" I'd like to know, just for curiosity's
sake.  Thanks!


------- Additional Comments From   10/07/99 03:05 -------
I run into the same proble while trying to switch to vi editing mode
in bash after installing RedHat 6.0 on my new PC box...
Removing INPUTRC from /etc/profile or explicitely unsetting it in
~/.profile effectively fix the annoying >-(  bug...

------- Additional Comments From   10/07/99 03:05 -------
I run into the same proble while trying to switch to vi editing mode
in bash after installing RedHat 6.0 on my new PC box...
Removing INPUTRC from /etc/profile or explicitely unsetting it in
~/.profile effectively fix the annoying >-(  bug...
Comment 1 Jay Turner 2000-02-08 09:02:59 EST
This is fixed in the latest installer code.

Note You need to log in before you can comment on or make changes to this bug.