Bug 546607 - gnome-screensaver looses mouse/keyboard after resume with external display
gnome-screensaver looses mouse/keyboard after resume with external display
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 583661
  Show dependency treegraph
 
Reported: 2009-12-11 07:15 EST by Robert de Rooy
Modified: 2015-01-14 18:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 583661 (view as bug list)
Environment:
Last Closed: 2010-12-03 20:48:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnome-screensaver debug messages (29.33 KB, text/plain)
2010-02-05 04:21 EST, Robert de Rooy
no flags Details

  None (edit)
Description Robert de Rooy 2009-12-11 07:15:29 EST
Description of problem:
Not sure this is a gnome-screensaver problem, but killing gnome-screensaver works as a workaround.

Basically when I suspend my ThinkPad T60 (Intel 945GM), then while in suspended state attach an external display (VGA or DVI), and open the lid to trigger a resume, I get the login screen on the LVDS, but no mouse cursor and I cannot type anything.

I can however switch to a VT, login and kill gnome-screensaver, and switch back and continue to work.

Also if this happens, after resume the external display does not get a signal, but the moment I do a VT switch it does get signal, and if I then immediately switch back, the mouse cursor is visible on the secondary display, but does not move.

Version-Release number of selected component (if applicable):
kernel-2.6.31.6-166.fc12.x86_64
xorg-x11-server-Xorg-1.7.1-12.fc12.x86_64
xorg-x11-drv-intel-2.9.1-1.fc12.x86_64
gnome-screensaver-2.28.0-7.fc12.x86_64

How reproducible:
every time

Steps to Reproduce:
1. Suspend
2. Attach external display
3. Resume
  
Actual results:
No mouse cursor, cannot type password

Expected results:
functioning mouse and keyboard

Additional info:
Comment 1 Osma Ahvenlampi 2010-01-19 03:18:18 EST
Acer TravelMate 6292, Intel GM965, same issues. It appears that the unlock dialog gets confused if the screen geometry changes while it's active. This is a regression from 2.26.

kernel-2.6.31.9-174.fc12.x86_64
xorg-x11-server-Xorg-1.7.4-1.fc12.x86_64
xorg-x11-drv-intel-2.9.1-1.fc12.x86_64
gnome-screensaver-2.28.0-8.fc12.x86_64

Steps to reproduce same as above.

Actual results:
Password/unlock dialog on LVDS screen, no pointer visible, no keyboard focus for dialog, can not type or otherwise interact with the dialog.

Expected results:
Dialog interactive.

Workaround:
Wait 60 seconds for dialog to time out and screensaver to reactivate, then touch the mouse or keyboard for dialog to reappear -- this time it works.
Comment 2 Robert de Rooy 2010-02-05 04:21:37 EST
Created attachment 389024 [details]
gnome-screensaver debug messages

With the below versions I started gnome-screensaver in debug before suspending. After resume I killed it which can be seen by the 'Terminated' message in the log.

gnome-screensaver-2.28.0-8.fc12.x86_64
xorg-x11-server-Xorg-1.7.4-6.fc12.x86_64
xorg-x11-drv-intel-2.9.1-1.fc12.x86_64
kernel-2.6.31.9-174.fc12.x86_64
kernel-2.6.32.7-37.fc12.x86_64
Comment 3 Robert de Rooy 2010-02-10 02:02:05 EST
I updated to gnome-screensaver-2.28.2-1.fc12.x86_6 but it has not made a difference.

I can also confirm Osma's workaround. Wait for gnome-screensaver to time-out and hide the unlock dialog. Then pressing a key and this time it does work.
Comment 4 Robert de Rooy 2010-02-18 10:30:42 EST
The new gnome-power-manager-2.28.3-1.fc12.x86_64 again makes no difference. I even tried if perhaps pressing alt-f2 and typing "pkill -f gnome-screensaver" would get me past the screensaver, in which case it would have been another security exploit as in CVE-2010-0422, #564464 but that does not seem to be the case.

Fact remains that gnome-screensaver looses input focus when suspending, attaching an external display and then resuming.
Comment 5 Robert de Rooy 2010-02-18 10:31:29 EST
ok, that should obviously have read gnome-screensaver-2.28.3-1.fc12.x86_64, not gnome-power-manager.
Comment 6 Robert de Rooy 2010-03-17 10:17:12 EDT
I tried F13alpha, and the issue is resolved there. It would be nice if whatever fixed the issue could be backported to F12, but I probably won't care any more in 2 months time when F13 is out.
Comment 7 Robert de Rooy 2010-06-03 05:51:18 EDT
Although I was not able in a quick test to reproduce it with F13 Alpha, the current final build of F13 has the same problem as before.

gnome-screensaver-2.30.0-1.fc13.x86_64
kernel-2.6.33.4-95.fc13.x86_64
xorg-x11-drv-intel-2.11.0-4.fc13.x86_64
Comment 8 Bug Zapper 2010-11-03 23:36:55 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Osma Ahvenlampi 2010-11-04 03:32:58 EDT
I have not seen this for some time on up-to-date F13 installation.
Comment 10 Robert de Rooy 2010-11-04 04:29:58 EDT
I no longer have the 945GM equipped ThinkPad. And on my new ThinkPad with latest generation Intel video, I have not seen this issue with either F13 or F14.
Comment 11 Bug Zapper 2010-12-03 20:48:23 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.