Bug 54669 - NFS exports available only through gateway device
Summary: NFS exports available only through gateway device
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nfs-server   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-15 23:04 UTC by Larry Hauch
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-11 10:50:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Larry Hauch 2001-10-15 23:04:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
A server with multiple ethernet cards has problems with RPC and NFS Server 
mounts through the an ethernet card not defined as the GATEWAY device.

If a client tries to mount an nfs drive using an IP address for an 
ethernet device that is not defined as the gateway, it gets an RPC timeout.

The /usr/sbin/rpcinfo -p nfsserver.notgateway.name will give a list of 
services, regardless of the gateway device, however /usr/sbin/rpcinfo -u 
nfsserver.notgateway.name portmapper will hang.  The client mount command 
will get an RPC timeout when trying to mount using the non-gateway device.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Setup two NIC cards on two separate subnets, using the eth0 as the 
GATEWAY device
2. then try either (from a second system on the second subnet) of the 
following:
    a) /usr/sbin/rpcinfo -u ipaddr.of.eth1 portmapper
    b) mount -t nfs ipaddr.of.eth1:/tmp/foo /mnt/foo
	

Actual Results:  for testcase 
2.a) the rpcinfo command will hang
2.b) the client will return with an RPC timeout error

Expected Results:  for testcase: 
2.a) should return with 
program 100003 version 2 ready and waiting

2.b) should mount the nfs share under /mnt/foo

Additional info:

This only happens with RedHat 7.1 using NFS server, but works correctly 
with RedHat 6.2 NFS servers.

Comment 1 Steve Dickson 2004-08-11 10:50:18 UTC
This seems to be fixed in later kernels.


Note You need to log in before you can comment on or make changes to this bug.