Bug 54676 - hard coded /home/user/.netscape path?
Summary: hard coded /home/user/.netscape path?
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netscape   
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-16 02:20 UTC by Need Real Name
Modified: 2014-03-17 02:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-17 14:32:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-10-16 02:20:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
The .netscape subdirectory is searched for in /home/<user> even though
$HOME = /mnt/home/<user>.  Hence, the cache and bookmarks are found
on an nfs server but not on nfs clients which mount home directories.  This
was not the case with older versions of netscape.

Version-Release number of selected component (if applicable):
netscape-common-4.77-1


How reproducible:
Always

Steps to Reproduce:
1.  start netscape from nfs server - it correctly finds the .netscape
directory 
2.  start netscape from nfs client - there are, for example, no bookmarks
defined.
3.
	

Additional info:

Comment 1 Michael Schwendt 2001-10-17 14:32:23 UTC
Works for me with 4.77-1 and 4.78-* from Raw Hide. 

Both the /usr/bin/netscape wrapper script and the binaries access
$HOME/.netscape (and $HOME/nsmail).

$ rm -rf /tmp/testhome ; mkdir /tmp/testhome
$ export HOME=/tmp/testhome
$ netscape

creates everything in /tmp/testhome/.netscape and also notifies the user about
missing cache directories. All in the new $HOME.

Comment 2 Bill Nottingham 2002-01-25 06:08:48 UTC
This also works for me in testing here.


Note You need to log in before you can comment on or make changes to this bug.