Bug 546811 - changelog dies from bad dates
changelog dies from bad dates
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
abrt_hash:125924ac
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-11 22:17 EST by Rob Wills
Modified: 2014-01-21 18:12 EST (History)
5 users (show)

See Also:
Fixed In Version: 1.1.25-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-12 15:32:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.11 KB, text/plain)
2009-12-11 22:17 EST, Rob Wills
no flags Details

  None (edit)
Description Rob Wills 2009-12-11 22:17:04 EST
abrt 1.0.0 detected a crash.

Comment: I was using yum to try and view changelog data for the recent totem package update

backtrace
-----
Summary: TB125924ac changelog.py:209:doCommand:ValueError: year out of range

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 315, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 180, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 351, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/lib/yum-plugins/changelog.py", line 209, in doCommand
    self._since_tt = time.mktime(tt)
ValueError: year out of range

Local variables in innermost frame:
tt: time.struct_time(tm_year=686, tm_mon=12, tm_mday=11, tm_hour=0, tm_min=0, tm_sec=0, tm_wday=5, tm_yday=345, tm_isdst=-1)
since: totem.i686
extcmds: ['0:2.28.4-1.fc12']
base: <cli.YumBaseCli object at 0x9deaeec>
msg_warn: <function msg_warn at 0x9f009cc>
msg: <function msg at 0x9f0095c>
logger: <logging.Logger instance at 0x9deae8c>
self: <changelog.ChangeLogCommand instance at 0x9ee6c6c>
basecmd: changelog

cmdline: /usr/bin/python /usr/bin/yum changelog totem.i686 0:2.28.4-1.fc12 
component: yum
executable: /usr/bin/yum
kernel: 2.6.31.6-166.fc12.i686.PAE
package: yum-3.2.25-1.fc12
uuid: 125924ac
Comment 1 Rob Wills 2009-12-11 22:17:07 EST
Created attachment 377828 [details]
File: backtrace
Comment 2 James Antill 2009-12-12 00:23:39 EST
 This is a bug, but what you want are:


1. List all entries in changelog:

   rpm -q --changelog totem

2. List all entries in changelog since June 2009:

   yum changelog 2009-Jun totem

3. List last 4 changelog entries:

   yum changelog 4 totem
Comment 4 Fedora Update System 2010-01-27 07:13:37 EST
yum-utils-1.1.25-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/yum-utils-1.1.25-1.fc12
Comment 5 Fedora Update System 2010-02-11 09:48:06 EST
yum-utils-1.1.25-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.