Bug 546955 - nslookup fails looking for libcrypto.so.8 when it shouldn't be looking for it.
nslookup fails looking for libcrypto.so.8 when it shouldn't be looking for it.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
12
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-12 15:49 EST by Eli Wapniarski
Modified: 2013-04-30 19:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-22 07:27:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eli Wapniarski 2009-12-12 15:49:42 EST
The bug should be filed against bind-utils which is not listed in the components list. hmmm.


Anyway. I recently upgraded my Fedora 11 installation to 12 and had cause to run nslookup.

nslookup failed because it could not find libcrypto.so.8. I worked around this by creating a softlink:

libcrypto.so.8 -> /usr/lib64/libcrypto.so.1.0.0


Whats a little weird about this, is that I have a clean install i386 install and I do not get the error message and, wouldn't you know it, libcrypto.so.8 is not in the openssl file for it, nor is their any softlink for it.

So, I'm making the assumption that nslookup shouldn't be looking for libcrypto.so.8. So I have to ask why is the upgraded installation looking for it?


Versions
--------
Fedora 12 x86_64
bind-utils-9.6.1-13.P2.fc12.x86_64
openssl-1.0.0-0.13.beta4.fc12.x86_64
Comment 1 Adam Tkac 2009-12-16 09:29:56 EST
Weird. Would it be possible to attach output from "ldd /usr/bin/nslookup", please?

If it still requires libcrypto.so.8 then please try to reinstall bind-utils package.
Comment 2 Adam Tkac 2009-12-22 07:27:38 EST
It seems this issue is already fixed, closing.

Note You need to log in before you can comment on or make changes to this bug.