Bug 547078 - process_body_receive can't handle of contents without final newlines
Summary: process_body_receive can't handle of contents without final newlines
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: purple-msn-pecan
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Itamar Reis Peixoto
QA Contact: Fedora Extras Quality Assurance
URL: http://groups.google.com/group/msn-pe...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-13 14:51 UTC by Simone Contini
Modified: 2010-01-03 21:01 UTC (History)
3 users (show)

Fixed In Version: 0.1.0-0.3.rc1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-02 21:31:04 UTC
Type: ---


Attachments (Terms of Use)

Description Simone Contini 2009-12-13 14:51:52 UTC
The program crash when it receive a contents without final newlines; If you receive messages after logout the application crash at startup (with automatic login).

I already sent the patch to the project author (see the URL), please include it in Fedora soon.

Comment 1 Fedora Update System 2009-12-16 09:01:00 UTC
purple-msn-pecan-0.1.0-0.2.rc1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/purple-msn-pecan-0.1.0-0.2.rc1.fc12

Comment 2 Edouard Bourguignon 2009-12-16 09:06:02 UTC
This package includes your patch. Please let us known if it works. Thank you.

Comment 3 Fedora Update System 2009-12-18 04:25:58 UTC
purple-msn-pecan-0.1.0-0.2.rc1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update purple-msn-pecan'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13302

Comment 4 Edouard Bourguignon 2009-12-18 08:59:11 UTC
*** Bug 547836 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2009-12-18 09:38:29 UTC
purple-msn-pecan-0.1.0-0.3.rc1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/purple-msn-pecan-0.1.0-0.3.rc1.fc12

Comment 6 Edouard Bourguignon 2009-12-19 12:58:12 UTC
*** Bug 547836 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2009-12-22 05:00:01 UTC
purple-msn-pecan-0.1.0-0.3.rc1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update purple-msn-pecan'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13525

Comment 8 Fedora Update System 2010-01-02 21:31:00 UTC
purple-msn-pecan-0.1.0-0.3.rc1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2010-01-03 21:01:51 UTC
purple-msn-pecan-0.1.0-0.3.rc1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.