Bug 54708 - Nautilus fails to pass "laugh test"
Nautilus fails to pass "laugh test"
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-16 15:09 EDT by Michal Jaegermann
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-16 15:14:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2001-10-16 15:09:32 EDT
Description of Problem:

Attempts to use Nautilus on a machine with
233 MHz K6 (AMD) processor is not only slow beyond any point when it
can be considered anything but a mere curiosity and a "test of a concept"
but it also brings the whole working machine practically to a halt.
It would have to be at least two orders of magnitude faster before
it can be seriously considered as fit for anything.  The situation
is aggravated by the fact that killing this monstrosity is not an
obvious task even if it is not respawned by Gnome sesssion.  Once
started, even from a terminal window, it keeps coming back.  This is
very nasty and antisocial behaviour.

Not mentioning this small detail that a user interface is bad and
confusing.  To clearly demonstrate that you can try to repeat a
trivial experiment which I did.  Try to ask a novice user, NOT a
Nautilus developer, to use Nautilus to switch a broken Help facility
to something else and see how this will go.  Extra points if a user
will end up with 'gnome-help-browser'.  So far everybody on which I
tried that miserably failed while there was at least a fighting chance
for the same task with 'gnomecc'.  The fact that after every try one
has to wait, and wait, and wait... with nautilus before someting will
happen does not help here at all.

If this is a meant as an interface for those with machines fast
enough that their patience will be still sufficient then it should
not be used as a default one but possible as an alternative.
Comment 1 Havoc Pennington 2001-10-16 16:13:30 EDT
The desktop isn't really intended to work on 233 mhz (though memory is the more
important factor in determining speed). 

In any case, gmc is still included, feel free to use it on old machines.
Nautilus is the default since it is nicer for people with more typical machines.
The speed issues are known, they are getting better, I'm not going to leave a
bug open for a general "could be faster" comment though, that doesn't help track
the work in progress.
Comment 2 Michal Jaegermann 2001-10-16 16:28:10 EDT
> The desktop isn't really intended to work on 233 mhz (though memory is the
> more important factor in determining speed).

Oh, really?  So how come that it worked for a number of years by now on
the machine in question, and quite well - thank you very much, and even
before this machine was upgraded to its "speedy" state.

I am afraid that this response only shows that the whole concept of Nautilus
as a default interface is arrogant and fundamentally broken.  It is not really
usable in any reasonable sense on a 750 MHz machine as well.
Comment 3 Havoc Pennington 2001-10-16 16:45:02 EDT
Because it used to work, and now it doesn't, because other priorities are higher
than working on a 233, and there is a tradeoff. The software is open source, and
gmc is still there. So you can set up your system as you like. The defaults are
for the "average" customer, the open source and configurability are so
non-average customers can adapt things to their needs.
Comment 4 Aaron Brown 2001-10-16 17:12:48 EDT
This is something that I wish we had more time to investigate.  Mostly
because of this:

300Mhz Cyrix CPU, 256MB RAM:  Nautilus FAST
850Mhz Celeron CPU, 256MB RAM: Nautilus SLOW
1.0Ghz Duron CPU, 256MB RAM: Nautilus OK
1.7Ghz Pentium 4 CPU, 512MB RAM: Nautilus FAST

This doesn't make any sense, especially on the 300Mhz box.  Nautilus
runs great on all the hardware I have here at my desk, but I know
for a fact it runs poorly for some people.  The only problem is
that I don't think this can simply be chalked up to "slow hardware".
Please feel free to investigate further.  I concur that this
is "notabug".
Comment 5 Havoc Pennington 2001-10-16 18:54:02 EDT
Yes, the varying results are not surprising to me. The kinds of things in your
directories, use/nonuse of NFS, and other sorts of things are important, plus
the kernel in use. 

It'll all get sorted out as we do more rounds of profiling.

Note You need to log in before you can comment on or make changes to this bug.