Bug 54716 - starting and stopping X logs out serial terminal users
Summary: starting and stopping X logs out serial terminal users
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: util-linux   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-16 20:04 UTC by Robert M. Riches Jr.
Modified: 2007-04-18 16:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-16 20:05:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tty initialization commands (1.83 KB, patch)
2001-10-16 20:05 UTC, Robert M. Riches Jr.
no flags Details | Diff

Description Robert M. Riches Jr. 2001-10-16 20:04:27 UTC
Description of Problem:
Whenever an X server is started or closed, that act (or
the PCI bus reset that seems to result) blows away the
login sessions of anyone using a serial terminal.  It is
likely the problem is somewhere other than /bin/login
(in util-linux), but util-linux was my best guess for
the guilty component.

Version-Release number of selected component (if applicable):
util-linux-2.10s-13.7

How Reproducible:
pretty close to 100%

Steps to Reproduce:
1. Person A logs in via a serial terminal.
2. Person B logs in via the console, starts an X server
  -OR-
   Person B logs out from the console, terminating an X server
3. 

Actual Results:
Person A's login session is blown away, and a login prompt
is issued.

Expected Results:
Person A's login session should not be affected.

Additional Information:
The serial ports in question are a Comtrol Rocketport 4-port
PCI card, using the open-source driver as modified by Harddata
to fix Alpha-related issues.  The driver is loaded as a module
into the 2.4.3-12 kernel.  I will attach /etc/inittab.  I'd be
willing to attach any other configuration files if needed.

Comment 1 Robert M. Riches Jr. 2001-10-16 20:05:17 UTC
Created attachment 34222 [details]
tty initialization commands

Comment 2 Elliot Lee 2002-01-04 19:06:08 UTC
There's zero chance of reproducing this bug without the exact same hardware
setup as you have.

I would guess that it is more likely a kernel problem (because it seems like
such a lowlevel thing), but I have no evidence at all. Since util-linux-2.10s
sounds rather old, you may want to try RHL 7.1 plus updates and see if your
problems go away.

You're basically on your own here. If you do come up with a patch that solves
it, I'd be happy to look at it though :)


Note You need to log in before you can comment on or make changes to this bug.