Bug 54726 - Adaptec 7896 problems with new boot disk
Adaptec 7896 problems with new boot disk
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-16 22:59 EDT by pcdreams
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-23 22:14:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pcdreams 2001-10-16 22:59:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
Using the patch boot.img disk to solve the known issue with the controler. 
I type linux apic. The system loads its startup files then the screen goes 
blank and locks. only way to get it to respond is do a cold boot.

System is an Intel ISP2150 no addin cards. 1 processor 6-mhz p3. 
terminator in 2nd slot. 64 mb ram  2 segate sca scsi drives and a ide cd-
rom drive. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot from patch disk
2.type linux apic
3.
	

Actual Results:  system hang with no video






Expected Results:  continuance of install

Additional info:

I was getting kernal panic:tryed to kill init!  before.  Did a couple 
changes in the bios(install os :changed to pnp, pci2031 bridge option now 
enabled, pci irq's to IO-APIC Mapping now disabled)
this got me out of the kernel panic situation but thats about it. 

I've seen lots of other post about the l440gx+ boards here but none with 
the specific problem with the video.
Comment 1 Brent Fox 2001-10-23 00:09:11 EDT
Does the anaconda installer even start or does it hang during the kernel boot?
Comment 2 pcdreams 2001-10-23 10:27:07 EDT
it hangs on the kernel boot. What I think is occuring is that the kernel is 
finishing loading ok(not sure because I'm new to this. but when it tries to go 
to anaconda I lose video(although I lose video before it has a chance to 
say "starting anaconda"
Comment 3 Brent Fox 2001-10-23 11:39:46 EDT
Since it seems that the kernel isn't even fully booting, I'm going to change the
component to the kernel.
Comment 4 Arjan van de Ven 2001-10-23 11:42:26 EDT
"changed to pnp" -> please change that back

also can you try "apic ide=nodma" as options ?
Comment 5 pcdreams 2001-10-23 22:13:55 EDT
ok now I'm getting the kernel panic again. I can't post a screen shot but I 
will type it out.

top part scrolls off screen but here is whats left. hopefully this will shead 
some light



Linux NET4.0 for Linux 2.4
Based upon swansea university computer society NET3.039
starting kswapd v1.8
vesafb: framebuffer at 0xf6000000, mapped to 0xc4800000, size 2048k
vesafb: mode is 800x600x16, linelength=1600, pages=1
vesafb: protected mode interface info at c000:3017
vesafb: scrolling: redraw
vesafb: direct color: size 0:5:6:5, shift=0:11:5:0
console: switching to color frame buffer device 100x37
fb0: VESA VGA fram buffer device
unable to handle kernel NULL pointer dereference at virtual address 00000000
printing eip:
c024ee58
pgd entry c0101000: 0000000000000000
pmd entry c0101000: 0000000000000000
...pmd not present!
Oops: 0002
CPU: 0
eip: 0010: [<c024ee58>]
eflags: 00010246
eax: 00000000 ebx: c0287040 ecx: 00000206 edx: c3fed638
esi: c0286ebc edi: 00000000 ebp: c0286e00 esp: c113ff88
ds: 0018 es: 0018 ss: 0018
process swapper (pid:1, stackpage=c113f000)
stack: c02870fc c024eb6b c024d1c9 c02509f8 00000001 c0105000 0006e000
       c024d226 00000000 00000001 c0105000 c024b36c c024b6d5 c024b399 c024285a
       00000001 c02428d0 00000000 00010f00 c0241fc4 c01070d5 00010f00 c0241fc4
call trace:[<c0105000>] [<c0105000>] [<c01070d5>] [<c0105000>] [<c01074fe>] 
[<c01070cc>]
code: f3 ab a1 2c 05 29 c0 c7 40 04 00 00 00 00 c7 00 00 00 00
kernel panic:attempted to kill init!
Comment 6 pcdreams 2001-10-23 22:34:10 EDT
Located the problem. Bad stick of ram.

thanks for the help
:)

Note You need to log in before you can comment on or make changes to this bug.