Bug 547410 - guest cpu stuck for 10s when guest is loaded
guest cpu stuck for 10s when guest is loaded
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2009-12-14 11:03 EST by lihuang
Modified: 2013-01-09 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-01 09:51:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
call trace in guest (26.47 KB, text/plain)
2009-12-14 11:03 EST, lihuang
no flags Details

  None (edit)
Description lihuang 2009-12-14 11:03:56 EST
Created attachment 378255 [details]
call trace in guest

Description of problem:
1. found calltrace in guest(attached is the log), I met the calltrace twice. one is when scp a large file(3.4G) from a remote machine to the guest. another one is when running iozone test inside guest.

2. nothing interesting in host was found.

3. the image files are on remote nfs server.

4. CLI:
qemu-kvm CLI :/usr/libexec/qemu-kvm -m 2048 -smp 2 -drive file=/data/images/t78/images/ChenZhou/5.4-64.virtio.virtio.qcow2.20,if=virtio,boot=on,cache=off -drive file=/data/images/t78/images/test2.qcow2.64k,if=virtio,cache=off -drive file=/data/images/t195/images/test1.qcow2.4k,if=virtio,cache=off -net nic -net tap -vnc :2 -monitor stdio -usbdevice tablet -uuid c3105705-6c51-40b5-80eb-a0ffa387575a

iozone CLI  :./iozone -aZR -n 16g -g 22g -y 32k -q 64k -M -b /root/result.xls -f /mnt/1/testfile

5. guest is RHEL5.4 X86_64






Version-Release number of selected component (if applicable):

Red Hat Enterprise Virtualization Hypervisor release 5.4-2.1 (2)
kvm-83-105.el5_4.13
kernel-2.6.18-164.8.1.el5


How reproducible:
reproduce twice so far

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Dor Laor 2010-01-20 04:32:01 EST
I'm not sure this is a bug, it might be due too stall by synchronous first time allocation done by qcow2.

Can you first fully populate the guest image by writing to the entire disk and afterwards erase these dummy files and return the test again?
Comment 2 lihuang 2010-01-27 06:11:25 EST
(In reply to comment #1)
> I'm not sure this is a bug, it might be due too stall by synchronous first time
> allocation done by qcow2.
> 
> Can you first fully populate the guest image by writing to the entire disk and
> afterwards erase these dummy files and return the test again?    

Yes. test 3 times,only reproduce when writing a fresh disk.

Note You need to log in before you can comment on or make changes to this bug.