This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 547425 - CLI should error out gracefully with an error message rather than blowing up if the required scripting libraries are not available
CLI should error out gracefully with an error message rather than blowing up ...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: CLI (Show other bugs)
unspecified
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: John Sanda
: SubBug
Depends On:
Blocks: rhq_triage
  Show dependency treegraph
 
Reported: 2009-12-14 11:38 EST by Preethi Thomas
Modified: 2014-05-16 16:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-16 16:13:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2009-12-14 11:38:13 EST
Description of problem:
CLI should error out gracefully with an error message rather than blowing up  if the required scripting libraries are not available

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. on an rhq-server machine which doesn't have the java script library
2.go to the cli/target/rhq-remoting-cli-1.4.0-SNAPSHOT/bin directory
3. run ./rhq-cli.sh
  
Actual results:
[root@10-16-120-159 bin]# ./rhq-cli.sh 
Exception in thread "main" java.lang.NullPointerException
	at org.rhq.enterprise.client.commands.ScriptCommand.<init>(ScriptCommand.java:83)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
	at java.lang.Class.newInstance0(Class.java:372)
	at java.lang.Class.newInstance(Class.java:325)
	at org.rhq.enterprise.client.ClientMain.initCommands(ClientMain.java:118)
	at org.rhq.enterprise.client.ClientMain.main(ClientMain.java:103)


Expected results:
error message

Additional info:
Comment 1 wes hayutin 2010-02-16 11:51:20 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 2 wes hayutin 2010-02-16 11:57:44 EST
making sure we're not missing any bugs in rhq_triage
Comment 3 Corey Welton 2010-10-05 09:16:17 EDT
 jsanda - is this even an issue anymore (since we don't support jdk5)

Note You need to log in before you can comment on or make changes to this bug.