Bug 54748 - update to util-linux-2.11f-11.7.1 breaks tcsh
update to util-linux-2.11f-11.7.1 breaks tcsh
Status: CLOSED DUPLICATE of bug 54741
Product: Red Hat Linux
Classification: Retired
Component: tcsh (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-17 16:27 EDT by Rex Dieter
Modified: 2007-04-18 12:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-23 07:20:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2001-10-17 16:27:05 EDT
Description of Problem:
After installing util-linux-2.11f-11.7.1 update, logging in via the console (or 
virtual terminal), accounts using the tcsh shell yields the error
Warning: no access to tty (Inappropriate ioctl for device)
Thus no job control for this shell.

Accounts using bash do not have this problem.

See bug #54741 (util-linux) for more details/dialog about it.
Comment 1 mikpe 2001-10-23 07:20:11 EDT
Same thing here. x86, RH7.1+updates, util-linux-2.11f-11.7.1 breaks tcsh for
console logins. strace tcsh reveals that an ioctl TIOCGPGRP fails with ENOTTY
with util-linux-2.11f-11.7.1, but succeeds with util-linux-2.10s-13.7.
Comment 2 Rex Dieter 2001-10-23 16:31:38 EDT

*** This bug has been marked as a duplicate of 54741 ***

Note You need to log in before you can comment on or make changes to this bug.