Bug 547493 - bibus-debuginfo-1.5.1-1.fc13 is empty
bibus-debuginfo-1.5.1-1.fc13 is empty
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bibus (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Alex Lancaster
Fedora Extras Quality Assurance
:
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2009-12-14 14:39 EST by Ville Skyttä
Modified: 2010-03-25 18:31 EDT (History)
2 users (show)

See Also:
Fixed In Version: bibus-1.5.1-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-25 18:31:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2009-12-14 14:39:51 EST
bibus-debuginfo-1.5.1-1.fc13 is empty.  As long as the package is temporarily not noarch, should its debuginfo package be disabled too?
Comment 1 Alex Lancaster 2009-12-17 18:09:44 EST
(In reply to comment #0)
> bibus-debuginfo-1.5.1-1.fc13 is empty.  As long as the package is temporarily
> not noarch, should its debuginfo package be disabled too?  

If necessary, I'm happy to do so.  How would I do this in the spec file?
Comment 2 Ville Skyttä 2009-12-19 06:53:55 EST
See the "DebugInfo" bug that this one blocks (bug 496968) for fix recipes.  For this case, it's probably 

%global debug_package %{nil}
Comment 3 Chen Lei 2010-03-07 11:13:07 EST
(In reply to comment #1)
> (In reply to comment #0)
> > bibus-debuginfo-1.5.1-1.fc13 is empty.  As long as the package is temporarily
> > not noarch, should its debuginfo package be disabled too?  
> If necessary, I'm happy to do so.  How would I do this in the spec file?    

Just add "BuildArch:      noarch"
Also bibus should not requires openoffice.org-pyuno, openoffice.org-writer python-sqlite2 and MySQL-python, it works well without those package.
Comment 4 Alex Lancaster 2010-03-08 02:44:15 EST
(In reply to comment #3)
> (In reply to comment #1)
> > (In reply to comment #0)
> > > bibus-debuginfo-1.5.1-1.fc13 is empty.  As long as the package is temporarily
> > > not noarch, should its debuginfo package be disabled too?  
> > If necessary, I'm happy to do so.  How would I do this in the spec file?    
> 
> Just add "BuildArch:      noarch"

That won't work because it needs to be noarch because it needs to generate the appropriate configuration look in the appropriate directory /usr/lib or /usr/lib64 for the openoffice.org libraries.

I think the approach suggested in comment #2 is the best i.e.:

%global debug_package %{nil} 

> Also bibus should not requires openoffice.org-pyuno, openoffice.org-writer
> python-sqlite2 and MySQL-python, it works well without those package.    

True, but because the OpenOffice.org functionality can't be selectively enabled in a subpackage, I'd prefer to keep those dependencies so it works out of the box for most users who will probably want to use this with OpenOffice.org.  It's a pity we don't (yet) have Debian's concept of "Suggests" in RPM/yum as yet.
Comment 5 Alex Lancaster 2010-03-08 02:58:24 EST
OK, fixed in rawhide (F-14) and I'll push an F-13 fix (that will close this bug), but probably not necessary to have F-11 and F-12 updates just for this issue.
Comment 6 Fedora Update System 2010-03-08 03:00:29 EST
bibus-1.5.1-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/bibus-1.5.1-2.fc13
Comment 7 Chen Lei 2010-03-08 06:43:30 EST
(In reply to comment #4)
> (In reply to comment #3)
> > (In reply to comment #1)
> > > (In reply to comment #0)
> > > > bibus-debuginfo-1.5.1-1.fc13 is empty.  As long as the package is temporarily
> > > > not noarch, should its debuginfo package be disabled too?  
> > > If necessary, I'm happy to do so.  How would I do this in the spec file?    
> > 
> > Just add "BuildArch:      noarch"
> That won't work because it needs to be noarch because it needs to generate the
> appropriate configuration look in the appropriate directory /usr/lib or
> /usr/lib64 for the openoffice.org libraries.
> I think the approach suggested in comment #2 is the best i.e.:
> %global debug_package %{nil} 

You are right.


> > Also bibus should not requires openoffice.org-pyuno, openoffice.org-writer
> > python-sqlite2 and MySQL-python, it works well without those package.    
> True, but because the OpenOffice.org functionality can't be selectively enabled
> in a subpackage, I'd prefer to keep those dependencies so it works out of the
> box for most users who will probably want to use this with OpenOffice.org. 
> It's a pity we don't (yet) have Debian's concept of "Suggests" in RPM/yum as
> yet. 
openoffice is not buildtime dependencies, people who have openoffice installed acturally don't need those dependencies actually, however people who don't need , openoffice at all have to download such a big package. Not all fedora users have a good internet connection speed. Also some other packages such as eclipse, netbeans don't have those additional dependencies. I highly recommand you split out openoffice dependencies, because there are some people who complained to me about bibus. 

The python-sqlite2 and MySQL-python are also not buildtime dependencies, so it may be better to let bibus user choose which databases he need(it's easy to choose). 

You can add a README.rpm instead to let people known what packages are suggestted to install.
Comment 8 Fedora Update System 2010-03-08 22:31:22 EST
bibus-1.5.1-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bibus'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/bibus-1.5.1-2.fc13
Comment 9 Bug Zapper 2010-03-15 09:34:17 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Fedora Update System 2010-03-25 18:31:21 EDT
bibus-1.5.1-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.